Very slow dashboard

I have mybook live and the dashboard is very slow. I can’t access it at all via Ethernet LAN on any computer, only via my router.

It has assigned and then it has initializing device please wait. After waiting an hour or so I get to the dashboard but when I click a link it just says please wait and is just unresponsive.

My router sees as a connected device and I can ping and also MY-DEVICE network name, but when I try to access the dashboard I cant get to it?

The drive seems to then just disappear from the newtwork…Then the green light starts flashing

Hi, welcome to the community.

Have you tried using a different web browser? Have you tried pressing the reset button in the back of the drive?

Also, try a different ethernet cable, and try plugging the drive into an outlet in a different room (seriously). The first thing you need to do is identify where the problem actually is. Have you tried on a different computer? Different port on the router?

This was working a week or so ago but anyway.

I have tried the reset button, I have tried different power socket, different router, different laptop, different operating system, different eithernet cable, different browser, different workgroup name, I have checked firewall rules, added to the safe list. I have checked my router and added port forwarding port 80 and 443.

Before I could still access the shared folder, just not the dashboard. I now can’t access the shared folder or the dashboard.

I am still receiving emails…in fact it keeps restarting a few times an hour, sometimes every 10 mins

WD Quickview can see the NAS but I can’t map to it

I have reinstalled MyBook Live windows setup and at the connect section can see a connected device at and this resolves to MYBOOK-LIVE…When it gets to checking your device it comes back saying there seems to be a problem.(configure the device, copy files to or from, browse the devices shared folders, map a shared folder.

I am going through a router then to a modem if this makes a different however this was working before. I have also tried my modem router and this is no good either. I feel as though it is the firmware. Direct connection straight to LAN does not work and any computer.

I am also a web developer and have some host file configuration installed on my laptop, however I have tried to access from another laptop with my work laptop turned off and I still can’t access anything.

Again. my router shows it connected as I can ping this. When I ping MYBOOK-LIVE is shows and is comes back Ok…Yet trying to get to the dashboard is basically unresponsive