Very Slow Dashboard access on My Cloud Mirror 8TB 2 Gen

Hi everyone.

Let me first tell a short story before talking about the problem.

I used to have a WD MycloudMirror 6TB 1Gen and a Asus AC68U router that worked very very well using my Retina MacBook Pro 15". In January 2017 I was traveling on vacation and my house got robbed. They took everything from my house, including the WD( with all its data) and the Asus router. It was a nightmare, but that is another story.

Last weekend I managed to get a replacement for my stuff based on the great experience I had before. So I bought an Asus ac87U router and a WD MyCloudMIrror 8TB 2Gen.

It took about 24 hours to transfer all the files to the WDMC and do the first macbook Time Machine Backup. I did everything over WIFI and had no problems. I have uploaded approximately 500GB of media and a 400GB TimeMachine Backup

But in the last 2 days the dashboard interface became very slow.

I have read a lot of threads about slow dashboard and people telling that the cause is that enabling DLNA and iTunes sharing and cloud access makes the WDMC scans the files and that uses a lot of CPU slowing the Dashboard. That makes sense because I put my ears next to the device and I could hear a moderate-loud noise of the fans, also the device didn’t go to sleep not even once since I turned it on for the first time.

In the other hand I must say that this new device is behaving very different from my old Mycloumirror 6TB 1Gen. The old device also had every share option enabled, I even enabled indexing of the main share “PEMA” on macOS by typing on terminal “mdutil /Volumes/PEMA -i on” and everything worked very fine, WDMC was very silent, the dashboard access was very fast, it took about 2-5 second to load the main interface after typing password and if I didn’t access it for a few moments, it should go sleep. Navigating through the folder and subfolders of my main share was very fast. The only situation I could remember that could slow it down, was the moment I got home and turn my macbook on for the first time in that day, then it started to do a complementary indexing of the main share (not the one that scans the whole drive), but in a couple of minutes the indexing was over and everything was normal again.

With this new device everything is slower, complementary indexing of the main share takes hours, the dashboard is very slow and most of the time it is not even possible to access it. Even time machine is slower, but I must say I did a test and I could transfer a 27 GB from the NAS to my MacBook Pro in 9:07 minutes.

I don’t know what is happening, maybe the difference is that with my original device I probably slowly filled it up with files over 2 years, not everything at once. Probably I also enabled the sharing features once at a time as I was learning how things worked. With this new one I threw all my files at once and enable everything at once, including the enable of the drive indexing (that I have already disabled)

I will give it a time to scan and process all the media. But I read a thread that a guy was telling that his device ran continuously for 2 years, without sleeping. Woow,mine was not like that! Mine slept every night and it was very silent. I never experienced that slowness before. (Before you RMA your Device ... let's talk about your problems!)

What would be an reasonable time for me to wait the WDMC complete the scans and start working the way I am used to?

Yes, I’m that guy… and that was on the WD Live device. It would be clicking away inside my closet and I didn’t know what it was doing until I finally investigated.

Today I got the same 8tb cloud as you have now, in fact two of them.
edit: Actually I have the 8TB single drive Cloud so I have no idea if the script would work on a 8TB mirror but you can always give it a try.

Now the indexing is not as bad as the gen1 devices although they may have fixed gen1 with the latest firmware, but since you have a gen2 we won’t discuss gen1 anymore. I discover from another recent post that it may not be a WD fix that improved the scans but rather the larger memory of 512k on gen2 vs 256 on gen1.

Thus you can wait for the scans to complete without too much problems other than slow dashboard. Regular access like watching movies should be just fine.

I am in the same boat. When I got my 8TB drives, I filled it up to the brim with files and I could hear and feel the heaviness of the drive as it tries to index everything. I decided to let it scan and it took about a week but for some reason after the scans were done, it still clicked every 2 seconds and while it did go to sleep, the cron would wake the device up at least 4 times a day and in the middle of the night (3am to check for updates even if you told it not to) the drive was awake; clicking every 2 seconds. When I got up in the morning, the drive was awake at 8AM. At lunch it woke itself up again. One more time at 3PM. It was annoying and frustrating even though my drive was across the room, I can hear the clicks.

So I gave up…
In the end I decided to turn everything off so the drive can sleep when not accessing…

here is my script for turning everything off.

/etc/init.d/wdphotodbmergerd stop
/etc/init.d/wdmcserverd stop
/etc/init.d/wdnotifierd stop
/etc/init.d/wddispatcherd stop
killall crond off
sleep 1 on 5

Make sure to turn on sleep from the dashboard before running this script.
Run this script after turning on your Cloud access even if you had ran it before turning on cloud access. It is a constant fight with the OS now because it starts up the scans every time you start up Cloud access, or turning on or off Cron and so on. For some reason WD turns the scans back on when you are not looking.

So just run the script whenever you make any changes to the dashboard. I do have Cloud access on for my Cloud drives so I can access it on the road. You can actually turn on Cloud access just by accessing it from the Cloud app but you have to be on Wifi to do this. Once you do this, run the script again to turn off the scans. You will still have cloud access but you won’t have thumbnails which is okay… really… because half the time you won’t get thumbnails anyways even with the scans and the reason is … just because its a WD App.

Once in awhile, I would turn off sleep so I can watch movies without the drive going to sleep. Don’t run the script when you do this. However once you are done with movie night, you can then turn on sleep from the dashboard, then SSH into the device and navigate through

cd /shares//Scripts <===Scripts is the directory that I store the above script.
./ <== is what I named the above script. Be sure to use the period to indicate the current directory.

When index is not running…
On gigabit ethernet, you should get between 80 to 100MB/s and that is Megabytes, not megabits. In other words 10 to 15 seconds to transfer a 800MB-1GB file.

On wifi AC, mine is with an Airport Extreme, I get approximately 40MB/s writes and reads.

on just standard Wifi, I get about 9 to 10MB/s read and writes.

With index running, I get about half the speed but at least the drive isn’t locked like my 4TB gen1 device.

If I remember correctly, as soon as I turned on media access or something like that, you can feel the whole drive bog down. So before you wait patiently for all the scans to complete, figure out if you really need what you are asking for, like DLNA. You definitely do not need the iTunes Server because if you drag all the music files into iTunes, it just picks up the links to your Cloud without the need for your Cloud to scan every media file to check if it is a MP3 file or not (I swear the WD scaners must be reading all your emails as well as reading every ebook you have and perhaps looking at every JPG stored on your drive.)

Recently I just found the VLC app for my Apple TV gen2 and it can access the Cloud drive without any type of index and it plays all the media files found on my Cloud.

I am just stoked at finally being able to remove my Mac Mini as the intermediary media server.

I wish you luck in whichever direction you choose. I don’t do WD’s tech support anymore but the guys like @Bennor and @cpt_paranoia does a great job in doing WD tech support without pay.

I had a ‘straw that broke the camel’s back’ moment some months back, when some inexcusable nonsense from WD made me think “that’s it, I’m not going to provide free support for them any more”. I’ve been pretty quiet since then, apart from sticking my oar in to point out the ongoing chaos that is WD product development/support.

I relent a bit on certain topics, but you have just reminded me that I need to stop providing unpaid support.

also it is a thankless job :stuck_out_tongue:

well WD seems to have most of the problems under control by ignoring everyone now :stuck_out_tongue:

our job is done…

Hey dude thanks for your reply.

I was messing around with my WDMC and I think my problem was solved with a firmware update.
I knew something was not right because after posting this thread I disabled everything, but even with everything disabled, the dashboard was still very slow. My 1 gen 6TB was a lot faster even with all DLNA, iTunes and cloud sharing enabled.

After the firmware update to My_Cloud_BWVZ_2.30.165, the 2 gen 8TB is a lot faster and I could start enabling things again because CPU was at 0%. I have just enabled cloud access, and seems all right until this moment, will give it a time, and will enable DLNA tomorrow or the day after

Thanks You

good luck Pemametal …

Hey Raphael.

I have been using my new MyClud Mirror for a while now. I turned on DLNA and Cloud access back again and after waiting a couple of days for the drive to scan and index, the performance was not as great as I expected (but definitely better than before I update the firmware)

I have not uploaded new files for a while and the WDMC folder navigation and dashboard is still kinda slow, when I disable cloud access and DLNA, folder navigation (through finder) and dashboard is really a lot faster and smoother, like night and day. So I really don’t know if this is the final performance I will get or the drive didn’t finish it’s indexing and will become smooth again after finish it.

I really appreciate if you could tell your opinion on that:

1 - Do you think the drive it is still scanning and indexing media? Is The index process supposed to finish someday or it will keep running constantly forever, even if I don’t upload files anymore? I mean, how can check if the drive has finished its index process?
Some observation is that fan is not loud as before, CPU is very inconstantly, it keeps varying from 20 - 80 up and down all the time. There is about 80 process running, but when I disable cloud access and DLNA, number of process reduces to 57-60. All that information from the dashboard. I am not into the SSH thing yet.

2 - My old 1 generation 6TB used to create the .wdmc folders in every folder that there were photos in it (as you related in other thread). But with this new 2 gen drive there is no .wdmc folders at all. Did they change this with a new firmware? Or maybe my drive is stuck in the thumbnail generation process and is not creating the thumbnails folders ?

From the years that I had the cloud drives, I always suspect that their indexing, thumbnails and other internal processing are a never ending processes. Even on my new Gen2 8tb cloud, the drive still clicks every 2 seconds. No idea what is causing the unit to do that but it is definitely a disk access of some sort.

For a mirror Cloud drive, I further suspect that it is a software mirror because I also watch WD strip everything that may cost a few cents more, like the blinking led, from their hardware. A software mirror could mean slower mirroring and could have the effect of non simultaneous mirror writing. meaning the mirroring occurs later after the data is written on one drive. Hardware raid of course is much expensive to create which may be in the older Gen 1 mirror clouds but not in gen 2. This is all speculation since I don’t have a mirror Cloud.

The only way to know for sure that you are still affected by the scans is to use SSH to stop some of the processes. If you are seeing on the dashboard the variations of the cpu, that means something is definitely happening throughout the day and it could be anything.

After I complained about the scattered .wdmc folders and told them to centralize it, they did. I believe it is now a hidden file under /shares. One of them is called .wdphotos, which I’m guessing to be the thumbnails folder which contains the wdphotos.db.

If your device is still sluggish and you don’t want to SSH into the device, then you have to wait for all the processing to complete; if ever. Last generation has showed that sometimes the scans do get stuck because of some bad movie file or photo.

Sometimes shutting down and rebooting helps because it clears up flags in the temp directory.

Another thing to try is the good old 40 second reboot, pushing a pin into that back hole and holding it in until it resets… you know the method… but after thinking about this, I think it deletes the scan folders and does it all again from the beginning.

Apparently the 40 seconds reset sometimes does wonders too… if you are lucky I remember that one time, that it stopped the scans automatically until you reboot (which you don’t ever again). It would be a message in your Alerts if this does happen.

Also remember that the latest firmware may have a SMB problem, at least on the single drive Clouds we do. Slower speeds, never sleeps, constant clicking due to some bug in SMB… which they will NEVER fix.

BTW if you do phone tech support, they will just have you do the 40 second reset anyways, then they will offer to trade your new cloud drive for a refurbished one; don’t do it… because you just get an older refurbished one with the same firmware which gives you the same problems… really…

Again good luck. Please post up again if you discover anything new because the customers that are providing tech support then uses that info to help others.

Hey Raphael,

Thanks for you fast reply

Actually, as my last try before going to SSH, I am currently doing a full system restore, after that I will manually reinstall the firmware (just to be sure things are correctly running) and start uploading files all over again. Do you think I need to redo a full restore again after manually reinstalling the firmware?

As curiosity. Why people do the 40 second reboot with the a paper clip in the back? Isn’t the same thing or even safer if you go to the dashboard and do the system only restore in the setting-> Utilities?

I think I can disable SMB access as I use a Macbook pro and it uses afp standard connection in finder to navigate. I even compared transferring a file via afp vs via smb connections. Afp was way faster. Copying A 27GB movie to my macbook was finished in 6:30 minutes vi afp and took more than 10-12 minutes via SMB. Is there any reason that I don’t know to keep the SMB enabled?

That is not an option. I live in Brazil hahaha (by the way I am sorry for my bad English) . I can’t call them, asking them to trade my device would take a very long time.

I will update this thread when I finish the system full restore and upload of the files.

Thank you very much for your advices

I think the 40 second reset is different than the restore, not sure though… but you should do a 40 second reset (if you feel you are having problems) after a firmware update. One of the major things that a reset does is to reset all the permissions.

I think the WD programmers uses this to clean up the system after a firmware that has gone wrong which happens quite often in the early days. Resets admin passwords, resets IPs I think, resets ownership, adds back the public folder that everyone tries to delete which subsequently probably causes a firmware problem when it tries to locate a non existent share.

AFP may seem to be faster but theoretically SMB 3 is suppose to be the fastest today of which the new firmware is suppose to support but in order to deactivate it in gen 2, I honestly don’t know how, but hopefully if you don’t attach via SMB then perhaps SMB won’t cause any problems.

I’m on a MacBook 12". Through ethernet, I get blazing speeds with SMB on my single drive cloud approximately 80-90MB reads and close to 50-60MB/s writes. AFP on the other hand is about half the speeds, although directory reads (file listing) on massive directories like my epub folder which contains about 25,000 folders and files, gets read in about 30 seconds compared to SMB which takes up to 30 minutes just to read the directory.

If you are ok with AFP, yeah it is a good idea to avoid SMB on the latest version until they fix it.

Oh wait a minute… if you are on a Mac, check this out …

Which may be the reason that your SMB is slower than your AFP.

So again… good luck… Thanks for keeping us informed of your progress.

Hey Raphael

From the WD support, They say the 40 second reset is equivalent to a “System only restore”, witch is available on dashboard. Actually there are 3 restore option in the dashboard. I don’t remember their names but one is the “system only restore” (that is supposed to be the same as the 40 second reset and you don’t lose any data) then there is a second option that you can recover data with appropriate software, and the full system restore witch erases everything.

"Option B: 40 Second Reset (Reset with Power Off)
The 40 Second Reset, also known as System Only Restore, will reset the following:

Admin User Name (default = “admin”)
Admin Password (No password by default)
Device Name (default = “WDMyCloudMirror”)


In the dashboard Settings - Network there are switches to enable and disable afp, smb and many others. Check yours, I know mine has that option, I can get a print screen for you when I get home.
But anyways I will try to connect via SMB3 and see if it is faster. I think when I did the comparison it was using SMB2.

I am using afp through Wi-fi, I have an ac router and my reading speeds is about 69 MB/s if I am correct (27 GB in 6:30 minutes)

I will take a look at this. Thank you!

If you are through WIFI AC and getting 69MB/s you are doing better than I. Max through Airport AC Extreme is about 45MB/s although I could peak at around 50-60MB/s.

I haven’t looked whether or not my single drive cloud has those options as I always used the three hand method of pushing a pin in the hole in the back. I think it would be more difficult in holding a mirror cloud, which is larger, with one hand and pressing the hole in the back with your other two hands.

It seems that you are very well versed on your cloud so my job is done here :stuck_out_tongue:

Hey Raphael,

I have finished the full restore. uploaded all my files, did a complete time machine backup, and enabled just the DLNA feature, no cloud access. So far everything is smooth and very fast. The dashboard loads in abou 2 -5 seconds, before it was loading in about 20-30 seconds. Folders and files loading when navigating through Finder via afp is really fast. I Could copy a 27 GB movie from the macbook to the WDMC in 04:54 that is equal a write speed of 91,84 MB/sec via WIFI. The device is even going to sleep mode when I stop accessing it, something I never experienced before with this device, only with the old one.

But what I found very interesting is the CPU activity. Look at this photo. I made 2 circles, one in the exact moment that I unplugged the cable of my LG smart TV and a second one in the exact moment I plugged the cable again.
Just for make it clear, the TV is not loading or playing anything from the WDMC, I am watching just regular cable TV, but the simple fact of plugging the cable makes the CPU of the WDMC go crazy. If I turn the TV off, the effects are the same as if I unplugged the cable, CPU goes back to almost 0% activity again.

envious… must be the read off a dual mirror. :stuck_out_tongue:

Must be the DLNA directory read, perhaps even thumbnail building and caching on the WD side.

Seriously, I’m envious. I was thinking of picking up a Mirror Cloud at one time, but the thought of having all my eggs in one basket kept me from buying one; that and also the price :stuck_out_tongue:

Yeah things are all right so far, but lets remember one important thing, I have not enabled the Cloud access yet, just DLNA. I will wait a few more days to see if the drive stays stable and then I will enable Cloud Access. After enabling it I will update here.
By the way I made a screen recording of the initial performance navigating through the menus of the dashboard and through the folders on Finder to compare when I finish enabling all the features. Then I will upload on youtube and post here.


1 Like

Hey Raphael, I wanted the post this a while ago but I couldn’t. As I finally enabled the cloud access and took screen recordings to compare. As I expected the problem relies on the cloud access. The performance is severely affected as you can see in the video below. It is very disappointing that we have to disable the cloud feature, the name of the device is Mycloud, come on, to get things working properly, …

well yeah… as soon as you turn on cloud access the scans starts up, of which you can cancel the scans with SSH which you do almost regularly because they WD has put in code to fight us by turning it back on when we are not looking; not kidding. I have no idea why WD is doing this because cloud access works perfectly without scans.

So once I turn on cloud access, I cancel the scans with SSH. Every night after I access the Cloud, I go in and cancel the scans whether or not they are running.

However theoretically if you let the scans run until it is satiated with data, it will return to optimal cloud access speeds. No idea if this ever happens, but you can be the first to tell us.

Thanks for posting up the video.

Thank you for all your posts over the years. What I have learned is that every time you post a work around, WD releases a firmware update that prevents us from implementing those work arounds. I have found a new way to kill those bloody thumbnail generators, not sure if it survives a reboot yet. So as to not ruin my fix, I will not mention it here as it could easily be over written in a future update.

Now the WDTV Lives were and still are the best Media Players on the planet, despite their slowness. They Play ISO’s, They play VOB, and they play M2TS. So I back up my media with Zero loss in quality from what came on the Optical Disc. You can also navigate DVD menus. No other media player does that well.

As to the Mirror, It’s a Storage device. You can’t expect a device with an Arm processor and miserable RAM to do a job an AMD FX-8350 with 24GB of RAM struggles with, but at least it finishes :slight_smile: .

I personally use a third party Media Center Manager software to format the file structure of my storage in a way that the WDTV Live works with. I run PLEX on my PC for when I am feeling lazy or just want to watch the already compressed stuff.

Eventually my mirror will get decommissioned as funds permit me to get my 2nd HP Proliant server running. They unfortunately have 2.5" cages so using them for mass storage just isn’t feasible. Mine was 2TB, Now has 8TB drives in it.

I bought my mirror on sale, it’s got a Marvell 380 series processor and I don’t know what gen that makes me. I only ever wanted for storage and an FTP server. I got one of the two. It doesn’t work well as an FTP server because it auto blocks frequent WAN users, I was using open offices “Save to Remote Server” feature to keep a central storage location for all of my machines. It’d work for about a week before the NAS would ban the IP.

Even with the media serving and indexing disabled, the thing isn’t efficient. Load Averages over 1 (when looking at TOP) mean that processes are waiting on the CPU. When photomerge is running, the box when need 6 of those 380 series processors to run efficiently and snappy. When connecting via SMB/FTP, it needs 2. NFS seems to not affect it at all. I have an NFS share dedicated to my ESXi hosted NVR with 3 cameras sending 8mbps to it constantly, and another 3 sending on motion.

My Warranty long gone, it’s not even in it’s original case. I built a case for it with a 120 mm FAN blowing cool air up from the bottom, and a 120mm fan at the top sucking the warm air out. Now I don’t worry when I get those FAN warnings, the built in fan just sits their to keep the warnings to a minimum.

I don’t know as I improved the conversation all that much, but I hope to have at least provided some insight for others to learn from.

My biggest advice - If you are a user with Zero real computers (you know the kind with a real keyboard and a real monitor and can usually heat your room so well you don’t need the furnace to run in the winter) and or rely on wireless only, don’t waste your money on a NAS with a weaker processor than the phone in your pocket. Get a NAS with at least an i3 in it. That way you don’t waste countless hours searching the internet figuring out how to make it perform better. If you don’t have room in your budget for the resulting electric bill, subscribe to Hulu or Netflix for entertainment and just use one of these weak NAS’s purely for storage.

In the current firmware they also have a bug that’s not killing old hhtpd processes. I am up to 4 processes now that were meant to (judging by Command, and factory enabled) restart httpd instances. Probably the 5 minute login timeout (restarting httpd would get you back to the login screen). They are using cpu cycles, just not that much. Maybe WD can fix that in the next firmware?

When you have a weak processor there is no such thing as a good bug :slight_smile:

1 Like

i would have very big interests to know the solution or at least the approach… would it be possible?