Very low speed of My Book Live 3 To


I have a WD My Book Live 3 To.

My network : A PC with a Gigabit connection and My Book Live 3To, both connected to a 5 port Gigabit Switch Netgear.

Both leds on the back of the My Book Live are green, showing a Gigabit connection.

The leds on the Gigabit switch are green on the PC and on My Book Live ports, showing a Gigabit connection for both devices. There is no other PC on the Network.

The Gigabit switch is connected to the Internet through a router with a connection 100mb.

The tests on the internet speed shows:

Ping 63 ms

Download: 1.52 Mbps

Upload: 0.23 Mbps

When the Internet connection is down, there is no communication between the PC and the NAS.

The copy of a a large file from the PC to the WD My Book Live is done at the speed of 30 k/s, meaning 7 to 10 hours for a file of 1 Gigabit.

Thanks to guide me and tell me what is wrong and what should be done to improve the situation, as the present status prevent me from using that NAS.

Thanks for your help.

Best Regards

Thierry Malbrancke

Hi, try checking your firewall, also check the link below to view some recommendations on how to improve your transfer speed.


Thanks for your answer. However, I had already read everything on the forum related to the slow speed of the WD My Book Live.

I had already read the recommandations mentionned on the link.
My configuration is shown on the third drawing (the PC and the NAS WD connected to the Gigabit switch, the switch being connected itself toe the router.

I had as well fully switched off the Bitdefender 2012 firewall and antivirus… But no change.

There is one thing I do not understand. The connection between the PC and the Nas does not work if the router is disconnected. This would mean that the PC does not communicate with the NAS WD through the Gigabit switch but through the Internet. Is this normal?

Thanks for your answer.


No, that’s not normal.  There’s something wrong with your connectivity somehow…  The MBL definitely doesn’t require your router to be up to work  (unless, of course, you’re using Dynamic IP addressing and the DHCP lease expires, and your router isn’t up to provide a new lease…)

Thanks for your reply. It has helped me solve part of the problems.

I have reconfigured my network, using fixed IP addresses.


The PC communbicates with the WD My Book Live through the Gigabit switch and not anymore through the Internet.

The speed, when copying a file from the WD My Book Live to my PC, is very good: 60 mo/s.

However, any copy from my PC to the WD My Book Live has not improved at all and is still very low; 29ko/s ; no change when Bitdefender Internet security (firewall & anti virus) is off.

Thanks in advance for any advice.

Best Regards


Try reading the WebDAV FAQ:


I have found the solution.

I have continued reading the memos related to the problem of speed in thedifferent forum.

I have found somewhere, it wzas a good idea to download and run TCP Optimizer, which I did.

The speed of copying to or from the NAS is now the same at > 70 m/s.

Many thanks for your help.

The good speed of 70 mb/s for transferring files frim my computer to the WD worked for 30 minutes. And then, without havind done anything, the speed came back to 30 k/s.

I am desprate and do not know what to change and where to search.

Thanks in advance for your help

Best Regards


This is a late reply to an old thread, but I can provide some feedback for those trying to get top speed or to speed up their WD My Book Live.  I have 3 TB edition.  I recently loaded the My Book with 500,000+ files that consumed about 1 TB.  I was using Robocopy (2003 edition) on XP, and it took 17 hours.  

Here’s what I learned:

  1.  Make sure that your PC is running on gigabit network.  I used cross-over cable to eliminate switch/router.  I had to set NIC in PC to 1000 mbps to get best performance.  Autodetect for network speed does not give good results.

  2. Size of files being written matter.  Large files can be written at about 35 megabytes per second.  Lots of small files reduce throughput to less than 5 megabytes per second.  In other words, the overhead to create a file is high.

1- that’s bad advice…  NEVER set to a manual setting unless you can also change the OTHER END manually as well…

Not to mention that unless you’re working with antique hardware a crossover cable shouldn’t be needed, as Auto MDIX eliminates that need