Veeeeeery sloooooooooow navigation round UI

My WD TV live has become almost unusable.  On switch on it works OK for the first 8 or 9 key presses on the remote and then grinds to a halt, typically I have to wait up to 20 secs between each and every key press. This is tolerable when trying to play a movie just a dozen or so key presses down but hopeless if you are tying to log onto a networked device with a username and password which can take 10 minutes to enter the detail as each and every time a key is pressed you have to wait for the menu to catch up.

This problem is the same on all branches of the UI irrespective of which device is being accessed or file being played.  It persists even if the USB drives are unplugged and I just try to use the network.

I have tried resetting to Factory defaults, doing a hard reset and checking my firmware is up to date (which it is) - none of which improves the situation.

Any ideas?

Skypilot617, maybe you should try contacting WD’s Technical Support about this. You can do so either by phone or email.

To Contact WD for Technical Support


Hi, yes I have experienced the same issues. Suggest rolling back to firmware 1.2.xxxx it fixed it for me however all the goodness of features provided by the later firmware disappears also :frowning: Both my units constantly hang when browsing through the menus after I watch any media - at least it then reset itself LOL.