VCD partition blocking drive recovery?


I have a MyBook Essentials 1.5TB that was knocked over while it was writing.

The drive fell out of the enclosure from the fall and now I’m trying to recover the files using the SATA port on drive itself connected to my PC’s motherboard.

The drive is detected as 1.5TB but shows as unformatted/uninitialized in WIndows Disk Management.

No recovery software I have tried(R-Studio, GetDataBack) finds any FAT/MFT on the drive.

I have tried raw recovery and it scans the entire 1.5TB drive but can only recover files from the VCD partition, I checked by looking at the surprisingly few recoverable .png files and they are all WD logos and Smartware logos from the VCD.

The VCD seems to be blocking the recovery. Did the VCD overwrite the MFT? Does anyone have experience with recovering files from a MyBook drive that has a VCD partition?

I know the warranty is already void with the drive being out of the enclosure but I want to retrieve the files and I’m sure that they are there if there is a way around the VCD.

I already had the VCD disabled before the enclosure fell. Should I flash the firmware? Can I flash from the SATA port or must it be USB?

Any ideas would be appreciated.

Did you have a password? if you did, then that’s the reason the data will not be recovered: It’s 256-bit physical AES encryption, the hard drive itself keeps it even if taken out of the enclosure.

It’s not the VCD, but the level of security what does not allow you to recover the data.

If you didn’t have a password, then… I’d contact a data recovery company if I were you…