VCD on Board not Disk

I’m wondering if the VCD is on a chip in the device and not a partition on the drive, here’s why: On my work PC I downloaded and ran the firmware updater which allowed me to see the drive in full. (1,500,152,938,496bytes) (perhaps the files for the VCD are on the drive but what mounts must be in between). After I ran the Firmware Update utility I tried to run the VCD Manager and it prompts me to connect a WD external disk, which it is attached.  I have the MyBook as E:/ and no VCD mounted or showing in the Windows Disk Management tool. 

So, I go plug the same drive into my Windows 2003 server and up pops the VCD in “My Computer” and I can’t do anything with the 1.36TB drive listed in the Windows Disk Management tool.  I bring the disk back to my desk and attach to my PC and I can write to the disk with no problems. 

Also there was a post a few days ago of someone who took the drive out of the enclosure and was able to use it directly connected in the PC, so that also makes me believe it is on some form of memory inside the enclosure. 

Does the Utility just write to the registry and not actually do anything to the disk?

I don’t believe the drive is compatible with Windows Server editions. Check on the product page in compatible OS.


I’m not sure how its not compatible if the VCD mounts and the software runs. They can say that they dont support it but thats another issue from it not working. 

I will try on another PC running XP and see what happens.

Same problem with using the Drive on my WinXP laptop.

NEVER buying a WD again! No wonder I got 1.5TB for $60. The case “logic” get’s in the way of using the drive normally!!!

We really should put together a class action to force WD to make firmware that get’s rid of their ironically named "smart"ware.