Various new problems after upgrading firmware (and then downgrading)

Yesterday I decided to upgrade my firmware for some reason, not sure why since everything was working fine.

After upgrading from the original firmware that came with the device to the 1.02.10 I noticed that:

1) I have to use a password to connect to my DataVolume/Download folder (annoying) —Solved solution below.

  1. Twonky will only list files in DataVolume/Public/Shared Videos.

  2. the admin site takes minutes load a page each and every time, making diagnostics painfully long and frustrating.

I did not experience the disconnect issues that everyone else seemed to have. I have since downgraded back to 1.02.06, but the problems persist. 

To attempt resolve the Twonky problem I have made sure that the folders are shared with all content types and verified that rescan is set to -1. I have also tried to restart the server and rebuild the database but nothing seems to make it work.

I was able to resolve the password protected folder. Creating a new user that was the same user name i log in to windows with apparently created the problem, deleting the user and creating one with a different user name solved this problem.

Any help would be greatly appreciated.


Edit- My device is the MBWE 2tb white light.

If you made the unofficial roll back then there’s nothing else to do other than waiting for the next (fixed) update.