v2.2.1.6 - useless - disgusted!

Today I upgraged to this software version as I noted my backups actually hadn’t been happening - closer examination showed that only system files were being copied and not data files - even though the Smartware software said they were!

After 5 attempts of loading, deleting and rebooting (over 5 hours), I finally got it to at least boot - it even looked like it was working!

On starting backup, the CPU usage is above 50% constatntly until the laptop freezes (at 38Gb of 120Gb to copy) and the only way to get it to work is to power down and reboot. After restarting the software, exactly the same thing happens. I’ve now been sitting for 9 hours trying to get this thing to work - I’ve trawled pages and pages of Support content and have came to the conclusion that it’s just down to this version of the software. I’m running Vista 32-bit and the drive is a MyBook 1Tb.

I have to say that as a professional photographer I have a few WD drives, but this will be the last time that I invest in WD products. This is a joke, and the other recent forum entries prove that I am not alone in my opinion.


I look forward to a solution very shortly via contact from your support staff.

I have raised a support ticket for this problem but to date have received no feedback from WD.


Tonight I have sent this email back to WD:


I am absolutely at my wits end with this USELESS WD rubbish!!!

Today I have sat for another 6 hours (15 in total now) and have done as you have suggested, plus other things, ie:

  • Removed and update MS .net software

  • Removed and updated WD Smartware

  • Removed and Updated WD SES Driver Setup software

  • Removed and Update WD Firmware to version

- Updated to the latest level of Flash

  • Made a donation to UNICEF, just in case…

  • Rebooted my laptop numerous times

  • Connected and reconnected my MyBook several times (and have had it blessed by a local Priest, again, just in case…)

Here’s where we are - I can’t even get the WD Smartware installer to load the latest level of Smartware (I’m trying for the 8th time here!!). When I double click the .zip file, the Smartware logo flashes onto the screen for 2 seconds, disappears and then …NOTHING!!!

It is quite clear that this WD product and software are rubbish, and has obviously never worked from the day it’s been purchased. In the UK, the Sale of Goods Act 1979, means that goods must be of a “merchantable quality” and also be “fit for purpose”. As neither this unit or software seem to fit this description, I now DEMAND  a FULL REFUND on my purchase price or a replacement unit that you can prove to me works as you say it does.

Please have someone from your UK operation call me tomorrow and discuss this issue - my number is xxxxxxxx…



Let’s see what response we get!!!

2 days ago I received an email from WD Support.

By that point I had completely given up on the Smartware software and had also formatted the MyBook with a view to using it as a dumb drive. I tried copying stuff to it and discovered that it froze after 8 mins use. I tried the same with another laptop and the drive froze after 7 mins. I am therefore assuming that the drive is knackered and that the Smartware software is rubbish.

I have informed WD Support that the only resolution I can see is a replacement unit, as my retailer refused to exchange it as it was more than 12 months old.

We’ll see what happens next…

6 days have passed since my last email reply to WD Support…and nothing.

It’s clear that both the software and hardware are flawed, and yet WD refuse to take anything to do with what is a legitimate complaint, judging by the feedback on this forum.

As I said in my header, disgusted…expected far more from a company of WD’s standing!

Where do we go from here WD??!!

Contacted by [Deleted] of WD, who called me from the Netherlands and left an email. Have replied to his email of 2 days ago and still no response back from him.

Have responded by saying that the unit is faulty and the software just doesn’t work, so I need a replacement unit or a refund under UK sales law.

Can I suggest that someone in WD get Michael in the Netherlands to read his emails and call or mail me back please.

I am royally sick of this now WD. Your company is truly a disgrace!


To follow up…

WD agreed with me that the MyBookLive was faulty and agreed to replace it, which they did with a MyCloud. Needless to say I was a very happy and satisfied customer at that point.

I now have a MyCloud that is every bit as useless as the MyBook. The new unit constantly drops off the network, and the only way to retrieve it is to manually cycle the power on and off!!

I was disgusted to see that there is a forum post on this very point that runs for pages and pages, but it as yet unresolved for many people - once again, a crappy product and software from WD.

I have disconnected the MyCloud and consigned it to the junk cupboard where it shall stay. A new Synology NAS takes its place and has worked perfectly and reliably since installed…says it all really, doesn’t it?!!