v1.05.18 NFS Share No Longer Works [RESOLVED]

Recently upgraded to firmware 1.05.18 via USB. I wasn’t able to re-connect to my NFS share after the firmware update. I did confirm it was working no problem prior to the update.

I did a factory reset twice and tried again but had no luck, when I select Linux Shares it finds the NFS server but when I select it the share can’t be opened. I also confirmed I can mount the NFS share on my Mac with no problems.

Any ideas on how to proceed? Or ideas to try?

Question: Is there a way I can download back to 1.03.10 (and where could I get that firmware file)? That was what I had earlier (skipped the 1.04.1 due to HDMI CEC bug).

Firmware version 1.03.10 is unavailable for roll back at the current time due to an issue discovered when rolling back to this firmware. WD recommends not rolling back to this firmware if you have already downloaded this file.

Just an update to this. I found my problem weird because the same weekend I updated I setup my friends with an NFS share on the same firmware version with no problems.

I seem to have tracked it down today - it seems I have to have a shorter NFS share path.

So  /home/username/downloads/complete doesn’t work while /home/username/downloads/  will map perfectly fine.  This is something I had trouble with on my friend’s setup as well but once I shortened the path everything worked correctly again.

I don’t think the name length is the issue, I think the fact you changed the name on the server caused “something” to happen where the WD box re-recognized the share. I couldn’t see my NFS shares either, got pissed as **bleep**, rebooted the PC a few times, rebooted and reset the WD box a few times, and suddenly, things all worked. Today, it doesn’t work. Somemthing is flaky and WD needs to fix it. But sometimes, it does work. But I’m pretty sure it’s not the name length! :slight_smile:

Hmm, I’ll try out some things tonight to narrow it down. 

I usually restart the NFS service after any change and also restart the WD box to alway start with a fresh state. Since I went with the shorter path the WD box has been working without issues.

Basically what I noticed was if the name was too long AND it was the only NFS share on that machine then the WD box would find nothing. If I had two NFS shares on that machine (one long path and one short path) then the WD box would pick up both shares but only the short path share would work, selecting the longer path share name would result in an error along the lines of no availlable content. I know that isn’t too much detail but this works on my WD box as well as my sisters WD box I setup over the weekend.

If you’re a severe linux geek, you can see if you’re getting this bug: