Using Windows Explorer

MyCloud is working fine under “Storage” and “Media Devices” in Windows Explorer, BUT it is not under “Network” (extreme left column in WE), so I cannot use Windows Explorer to move or transfer files. Someone said I need to map the drive but I have been unsuccessful in exactly how to do this. Step by step instructions would help - or any other idea!

First step, make sure SMB1.0/CIFS is enabled in Windows. Microsoft disables this setting in new Windows installs and through certain patch updates. WD Support has the following Knowledgebase Article:

How to Enable SMB 1.0/CIFS File Sharing Support on Windows 10

For directions on how to “map” a Share on Windows, see the following WD Support Knowledgebase Article:

How to map a My Cloud or NAS device on Windows

What version of Windows are you using, is it Windows 10?

If you have windows 10 have you ever tried a search using your favorite search engine or typing key words in the search box next to start? In your case, type Map network drive and check out all the information that shows.

I seem to have stumbled upon the same issue, but I just upgraded to OS5 from OS3.
It was working fine on OS3.
I still haven’t figured out what the issue is.

I got the latest windows, I have enabled SMB1.0 and I have made sure NFS is enabled.
Yet it’s not in the network discovery.
I have tried WD’s own Network Discovery tool.
No luck there.


You may want to see the dedicated OS5 subforum for your device to see if there is further information there on specific settings in OS5 that may contribute to causing the device not to show up properly in Windows File Explorer.


Usual troubleshooting steps should be tried if they haven’t already:
Reboot all network devices. My Cloud, router, computer, etc.
Try accessing the My Cloud by it’s IP address.
Ensure the My Cloud has a reserved or static IP address.
If the My Cloud Dashboard > Settings section (probably under Network) has an option to configure SMB version, try setting it to the lowest SMB version.
Temporarily disable any computer firewall/security software.
Make sure Windows Network Profile for the network connection is set to Private and not Public.

I found a solution, even though it’s not the best.

Good job tracking down one possible way to fix that issue. Bad news is that you has enable FTP and NFS, in your case, to get things to work for you in Windows File Explorer. One should not have to enable either of those options just to see the device in Windows File Explorer. That seems like a a serious bug. Either with the OS5 firmware or possibly another change by Microsoft via one of their updates, that breaks access to the My Cloud.

I find it to be OS5, because it has always been working with OS2 and OS3. It was working with OS3 before i upgrade to OS5.