Using storage like a memory stick vs going online

When I first hooked up my cloud home, I was able to click and drag files to it as if it was just another hard drive, thumb drive, etc. But now it tells me I have to log in, but I never set anything up to start with like that. It just showed up on my computer. I hate using online vs on my computer as if it was just part of my computer. It takes a lot more steps to add things to it and retrieve files. Any idea how to get it to let me back in like that? I have talked to support multiple times, but they aren’t understanding what I am trying to say and I can barely understand them. So it’s an hour of back and forth and not getting anywhere.

Hi @Conniekoenig,

Please refer to the article My Cloud Home: Drag and Drop Upload Type Not Supported by Browser:

Please contact the WD Technical Support team for best assistance and troubleshooting:

The new sign in process was introduced in early 2022 for increase security. Once authentication with WD account is done and WD Discovery installed, files in Mac Finder or Windows Explorer will again be available for copy and paste as before.

What is a Western Digital Account?
There is a new way to log into My Cloud™ Home, My Cloud™ OS 5, ibi™ and WD Cloud™ devices using Western Digital Account. This account provides greater security and a more consistent experience when accessing different Western Digital products.

Why did Western Digital transition to a new sign in process flow?
By moving to a single account and sign in process, you will enjoy a more consistent experience when using different Western Digital products.

Which products transitioned?
My Cloud Home, My Cloud OS 5, WD Cloud OS 5, ibi and EdgeRover.

When did the transition happen?
The new sign in process was introduced in early 2022.

I have tried to contact support and I can’t understand who i’m talking to. Their accent is not what I can understand. I have tried 3 times and it’s just too complicated to understand what they are telling me. So that’s not working. I even tried the chat function and they don’t understand what I am trying to tell them.