Using my Network drive to hold my iTunes media files - how to?

OK the network drive I bought is a 4Tb My Book Live Duo (MBLD) and I noted that it did say on the box words to the effect of “Increase your iPad storage”, so I thought about keeping all my iTunes media files on this drive and accessing them through iTunes on my Windows 7 64-bit laptop PC.

I think there are two problems that I am experiencing, the 2nd being a kind of knock-on effect of the 1st:

  1. Every time I reboot my PC, I currently have to enter a username and password before I can access my Network drive.

  2. iTunes searches for it’s “Media folder” (which I have set to be on my Z: drive - the MBLD), cannot find it because of 1) above and so resets it to the default location on my C: drive.

I accept that I may have made a few assumptions in number 2) above, but I reason that this is what happens because if I am quick enough to enter the login details before iTunes launches after a reboot (so the MBLD is enabled manually by me in time), then the Media folder remains as I want it to be, namely the one on the Z: drive

So, my feeling is that if I can fix 1) above, then the iTunes issue will probably sort itself out.

So, how can I ensure that my MBLD re-connects after a reboot without needing someone to manually enter a username and password?

Cheers in advance for any ideas …

Simon.

Do you get prompted for user name and password or the password request comes when you try to access the drive on the network?

Did you change the default password on the drive?

Is Z a private folder?

You can try copying the files to the public folder for the itunes library

for more information about the library check this link

http://wdc.custhelp.com/app/answers/detail/a_id/2724/session/L3RpbWUvMTM0ODI1NTcxNi9zaWQvdksxVypQNmw%3D

Hi thanks for getting back to me.

I used Map Network Drive to assign the letter Z to my MYBOOKLIVEDUO drive.  So, if I navigate to Z: in Windows Explorer now, I see the contents of my Western Digital external network drive, as required.

My problem appears when I reboot my PC (Dell Studio laptop).  If I go to Windows Explorer immediately after rebooting and navigate to My Computer, I see this:

a

Then, when I double-click on the Z: drive, I get the following login dialogue box:

b

and then finally, after entering my User name and Password, I get this:

c

 Now, the files on my Z: drive can be ‘seen’ and so my iTunes can use files from this location.  My problem is that if I don’t enter these credentials quickly (straight after boot up), iTunes chnages the location of its Media drive to the default one on the C: drive, which I don’t want it to do.

What I would prefer would be to not have to keep on entering these logon details every time I reboot my laptop - should it really be necessary?

Regarding your questions, in all honesty, I’m no computer wizard whatsoever, so how do I find out if Z is private?  What is a public folder and what is a private folder?

Click the checkbox to remember your UID / Password.

Untitled.png

I do this every time - I still get re-asked for the credentials after the next boot.  I get the impression that “Remember my credentials” box is meant to be just for the current login session - because it sure doesn’t work for any future sessions.

Anyone have any more ideas, please?

cyman1964uk wrote:

 I get the impression that “Remember my credentials” box is meant to be just for the current login session

No, that box is supposed to remember your credentials after logouts / reboots…  at least, it does for me…

Aha!  So do you see this box, then?

No, because I’m not prompted to log in again.

So you recall seeing this just once, entered your details and then you never saw it again, right?

Exactly.

Could it have somthing to do with the Duo being asleep when the computer comes online, and not responding to the mapping fast enough… then Windows thinking the connection is being ignored so it times out. Then asks for re-entry.

Just a guess here…

I had the same behavior. After rebooting I had to always enter my password. Using this Microsoft Question (look at the “Most Helpful Reply” not the “Answer”) as my guide, I was able to fix it. I’ve entered the steps I followed below, as best as I can recall.

  1. I unmapped my MBLD drives.
  2. I went to the windows 7 control panel’s Credential Manager and clicked on the Windows Credential entry for my MBLD.
  3. I noticed on Persistence, it said “Session” or “Login Session” or something similar. (All my other credentials said “Enterprise”.
  4. I copied down all the other values.
  5. I clicked “Remove from Vault”
  6. Clicked “Add a Windows Credential”
  7. Typed in the network address, username, and password.
  8. WHen I looked at the newly created credential, it was Enterprise persistence.
  9. Remapped the network drives
  10. Rebooted
  11. I was able to access my mapped drives without entering the password.

I’m unsure what determines whether the credentials become non-Enterprise. I’m guessing I must have done something wrong when I first set up my share, since it seems most other users don’t see this problem. I suppose they have Enterprise persistence. Does someone who knows more about this than me know what is going on?