Using as digital video signage (Autoplay Video)

Hello and thanks for reading my message.

We have purchased a WD TV Live Hub for use as digital video signage in our lobby.

I am running into a problem with the screen turning black after anywhere from 2-5 times through the loop.  Basically I have set two videos on the Internal Storage - one video is about 4 minutes long, the second video is 15 seconds long.  I have tried both .mp4 and .mkv files with the same result - same two files.

When I first opened the box I upgraded the firmware to 3.08.14.  The only settings I have changed are:

  1.  Video Settings | Video Playback Sequence… “Repeat All”

  2.  Operation | Auto Play… “Auto Play Video” (Internal Storage at root directory)

Once I started seeing this issue, I did downgrade the firmware to 3.05.10.  I did reset the settings by pressing the button on the bottom and reset through the menu.  I went back and adjusted the Repeat all video, and set Auto Play Video to the internal storage.  I then unplugged the unit for about 15 minutes and then turned it back on.  The unit then played the two videos completely through 2 times then stopped after the first video on the third loop.  

I then went ahead for sake of argument, updated the firmware again to 3.08.14.  I reset the settings again by pressing the button on the bottom, then through the menu.  Once it came back up I changed settings again to loop video and auto play video.  It played completely through 4 times, then played the first video 1 time and black screen.   I reset the entire device again and left it unplugged for 5 minutes and again - it played 4 times through then the first video 1 time.  

So I thought maybe it was the video files… I removed both of the original files I had been trying to use and put two different video files on and again.  I will play a couple times through then just a black screen (not the WD screensaver) - I can press the Home button on the remote and the menu comes up but the loop has stopped.

I am just working with a couple of video files first to make sure I can get the unit to do what I expect it to do.  But so far I am not seeing much consistency.

I would appreciate any tips or advice -

Thanks in advance

Have you tried to change the HDMI cable or the HDMI port?

Try a different TV.

ragdexx - thank you for the suggestion.  I have a bit more information…

First, I apologize for the delay in getting back.  I was hoping to do a bit of testing Friday, but we ended up with a sleet/ice storm so I am just getting to work on this.

I tried a 2nd television and a 2nd HDMI cable.  What do you know - it worked - played through at least 10 times until I turned it off.  So I began my process of elimination troubleshooting.  I brought back the original HDMI cable but the 2nd TV - it played through 10 times until I turned it off. 

This puzzled me - but then I noticed something.  I didn’t have a Cat5 cable plugged in so it wasn’t getting network access. So I plugged in a Cat5 and cycled the power.  It played through 2 times and stopped.  

So I returned to my original setup  with everything hooked up (original TV, original HDMI and network connection) it played 1 time through and stopped.    Without the Cat5 it works.  

At this point, the way I have found to make this work is:  I only have the HDMI going to the television and the WD TV Live Hub is without Cat5.  

I have tried taking the DNS and Gateway settings to in the network setup without success.  I have also tried different Cat5 cables without success.

Are there any services or options I can turn off or disable which may help where I can have the WD TV Live Hub connected to the network?

I have narrowed down the issue to the network connection.  I left the WD TV Live Hub running over night without the network cable connected, it is still running today looping 5 videos. 

Basically what I have found is the until will loop videos as long as the network cable is not connected.  However once I plug in the network cable it will only play through 3-5 times then give me a black screen (not the WD screensaver, but I can press the Home button on the remote and it will bring up the normal menu).  I have not been able to see a pattern as to how many times it will play through before giving a black screen.  But once I remove the network cable, it will loop continuously.  

It is not ideal, but I can live with this.  It would be nice to have it connected to the network to add and remove content to the Hub over the network at any time.  If anyone has any advice I would greatly appreciate it… also just as a FYI I did update to the latest firmware (3.09.18) yesterday as well - same results.  I have had the same results with 3.07.14, 3.08.14 and 3.09.18 firmware.