Users Can't Access Limited Dashboard remotely on EX4?

After hours and hours of trying to to get this EX4 working correctly, i decided its time to ask for help…

So here’s what im working with,

I have an EX4 with multiple users to access files using the web file viewer remotely… or i did for a short period of time. I also have a DDNS host setup with no-ip (payed version) so I dont have to look up my outside ip. For example, two days ago a user could have gone to and it would have gotten me to a limited dashboard where they could access file viewer.
I also have my dns host name running a port 80 redirect to 443.

Today it doesnt seem to want to work. Nothing has changed. Outside IP still the same. Everything matched in NO-IP.
I get a webpage stating this webpage is not available, with a little Western Digital logo in the top of the toolbar.

I had it working perfectly for 48 hours then nothing…

FTP is setup and working. (some of my users use ftp and some it doesnt work well for them)

Thats why im trying to setup an alternative to FTP.

Any advice would be helpful! Thanks!

Running the lastest firmware version.


Welcome to the WD Community. 

have you tried using only the website name without the username?

Also try

Are you running the dynamic update client on any computer on your network? Make sure that you have that running as this will update the information in case your ISP does changes the IP.