Username / password issue

I have Mycloud set up as a mapped drive in windows7 for file backup and also access these files from  a laptop when away from home.  I am able to do both but wonder if I can set up the username/password capability to allow auto connection of the mapped drive on win7 startup while still maintaining password protection when using the laptop/internet conection.  Currently, I do have password protection when connecting remotely, but I have to enter my username everytime the PC boots. 

When you map a local network share to a drive in Windows, Windows can store the credentials in its store, so that you don’t have to reenter the credentials at logon time.

When you map a remote network share, you actually map to a Webdav server through an http connection. Googling around here is what I found.

This one suggests you can use the windows credential manager

http://social.technet.microsoft.com/Forums/windows/en-US/6db0451d-d12d-40c0-a31b-708b2614ac88/credentials-prompt-for-remote-webdav-server?forum=w8itpronetworking

This one suggest you can edit the registry

http://www.geeks-on-wheels.net/solved-unable-to-save-remember-password-for-mapped-webdav-folder/

Neither of the above suggestions did the trick.  After doing some goggling and trying some other things, I found the solution after some more trial and error.  

First designate a share drive letter for the folder in WDMYCLOUD, making sure the"use different credentials" AND “remember my credentials” are both selected.  The key to allowing a mapped drive to re-connect at boot is to preceed the username with the name of the target device (domain), followed by a backslash.  In this case, the Username field is

WDMYCLOUD<username>.  The domain name should now show WDMYCLOUD.  Once you have done this, verify the shared drive by opening the Windows folder.  The drive should apprear in this window and clicking on this share should open the shared folders.  The share will automatically re-connect at startup.  I have tried this on two different PC’s and they both re-connect at boot automatically. Hope this helps anyone with the same issue.

Sure, this is the way to do it for mapped drives on the local network. Did you try with a connection from outside your home?

Yes, I used my laptop with the installed WD app and connected without any problems using the username/password previously set up.

I meant, were you able to map your shares to a drive on your computer when you were remote (not accessing through the WD desktop app, but using W2go.com, connecting to the share and using that URL to create a standing mapped drive that reconnects automatically on logon when you are remote).