Use HTTP:// instead of FTP://

@bennor: I followed your very good and easy howto and it worked like a charm :+1:
When I have more time I’ll try to get SSL/TLS work on the my cloud.

Thanks for all your work!

Did someone tried this for the Mirror too?
@nogood postet your giude to the german section and i tried it but it doesn’t work for me.
I can acces the folder i created (in /var/www/ xxx.xxx.xxx.xxx/ftp and i get the login screen from monstaFTP but after the login i became everytime a white site and in the logfile i can’t see any login with ftp. If i restart the Mirror the folder is removed.
If i put it in /var/www/htdocs i haven’t access to the folder under xxx.xxx.xxx.xxx/ftp.
Are these two systems so different?

Sorry for my bad english.

you need to make the folder “/var/www/htdocs/ftp” not “/var/www/htdocs/xxx.xxx.xxx.xxx/ftp” and put monsta in the ftp directory.
Make sure FTP is enabled on the UI as well, set up the correct port forwarding.

Also i did manage to get FTP working with SSL (guide: [HOWTO] Securing ftp server with encryption - #5 by jamalaya )

Some of the format got messed up on that guide though so heres (hopefully) the conf lines

rsa_cert_file=/etc/vsftpd/vsftpd.pem
rsa_private_key_file=/etc/vsftpd/vsftpd.pem
ssl_enable=YES
allow_anon_ssl=NO
force_local_data_ssl=YES
force_local_logins_ssl=YES
ssl_tlsv1=YES
ssl_sslv2=NO
ssl_sslv3=NO
require_ssl_reuse=NO
ssl_ciphers=HIGH

make sure to forward ports 5000-5099 and 21-22

As an additional question im having issues with redirects to the UI
I have my domain set up to link to www.xxx.xxx.xxx.xxx/ftp but once the link opens it redirects to /UI/
Can i easily move the UI onto another port (like 443 or 8080) ?

The correct folder on the My Cloud (and I assume My Cloud Mirror), per the directions (step 7) above in my post, is: /var/www/htdocs/ftp

I tried it again without any success. Now i installed wordpress to see where the files are saved. I is saved at /var/www/wordpress and has a link to /mnt/HD/HD_a2/Nas_Prog/wordpress. I’ll show you the content of the folders.
/var/www/

/var/www/htdocs/

/mnt/HD/HD_a2/Nas_Prog/

At least i put the ftp Folder to /mnt/…/Nas_Prog and did a link from /var/www/ftp to it.
I have access to it over the Browser but after the login in i ever have a white site.
I tried it with the Raspberry Pi and it worked well.

Edit:
After a reboot the Folder under /var/www is deleted itself again.

Certain NAS will reset the system mount at boot, this is the reason why I dropped my intention to get the EX4. There should be some way to overcome this, perhaps run a cron at boot to deploy your mods. You’ll have to ask in the MyCloud Mirror section as most of us here don’t have the MyCloud Mirror to support.

1 Like

Thanks. I thought so. I think i dont play with the cron handler on this System.

I read the thread and I’ll try to enable SSL too.
There schould be a warning:

Before opening Port 22 it ist absolute necessary to change the root password!

SSH log into My Cloud and than type: passwd and then type your new password twice.

Good info. I can FTP into MYCloud without anything other than FTP turned on and FTP from Windows Explorer. I guess from a remote PC or phone I would need something extra, or would I just need the external IP address plus correct port?

You’ll need to setup the port forwarding on your router as it doesn’t use UPnP to automatically open the FTP port.

Again please note the credentials are being sent in clear plain text which is not even hashed. No matter how strong your password is, your NAS is open to vulnerabilities especially when connected to public network. Use at your own risk.