Usb :-(

Hi there!

I think WD has created an amazing piece of „minimal - down to it“ hardware with its „My Cloud“.

this little box is:
very fast for what its designed, economic when it comes to
power consumption, small in size - huge in TB, discreet looking and hey, I can even easily access it from all over the world!

OK, the firmware (software?) has steadily improved since summer 14, but by then it was pretty much the bottom.

sorry to say.

What i don’t understand is why it is still not possible to fix once and for all the (obvious if you look at the community?) problems with some usb (-driver chipsets?) external drives.

My external HDD-enclosure works on every other computer, but not on the MyC: If connected to MyC I can see it for few minutes on the UI, it got correct name and model, then it disappears to nirvana… (when I’m „lucky“ I’m able to make a few minutes of Safepoint backup, which doesn’t help at all, of course)
MyC is then still fully responsiv over ethernet. USB, however, is dead until I restart MyC, then back to “normal” again with other devices, which I tried on it.

Firmware Version: v04.01.03-421

USB-Chipset of my enclosure: Genesys Logic GL3310 (usb3) (this chipset seemd to be on the market since 2010, so it’s not entierly new…)
HDD is a WD Green 3TB in HFS+J

To be honest: Might it be an idea to check a few more USB-chipset-hdd-combinations before they call the second plug on the back of MyC a USB-connection?

But still, I’m convinced that the MyC could (is gona?) be a pretty much perfect device!



Welcome to the WD Community.

Thanks for sharing your experience with us.

Have you tried contacting WD Support for direct assistance.

WD Contact info:


First of all: thanks for your reply, ERmorel!

What first looked like a incompability with my external hdd-usb-enclosure seemd to be actually an issue with some hidden (at least for my mac osx 10.9) partition.

When I first connected my brandnew WD Green 3TB placed in my USB-enclosure to my mac, I was asked to format the disk. Did that in Disk Utility to HFS+.

What I didn’t know is, that it also created (allready existing?) some sort of a hidden FAT32…

…Which “mixed up” somehow the USB port on myC (first post) with it’s several partitions on the disk, but any of my computers I connected my USB-drive to.

I found this “hidden problem” only on a friends linux.

We cleaned the drive completely and put ONE proper HFS+ part. on it…

…and voilà the myC safepoint does what it’s supposed to do: a backup!

To WD: I think it would be good to check and fix this issue when using a USB-HDD with more than one partition or at least mention it in your myC manual…

greetz. adapter.