USB Wireless Key Not Recognized


#1

I have just bought a WD TV Live for Christmas. It works OK with my WD Passport drive and I have no problems playing the media files. However, when I connect a NetComm NP545 54Mbps Wireless USB Adapter, it doesn’t recognize it. I am running the original firmware, v1.01.00. Would a firmware upgrade solve my problem, or do I need to buy a compatible USB Wireless Key? Thanks in advance.


#2

When you say USB Wireless Key to you mean USB Wireless Adapter? If so Yes is the answer to your question. I tried serveral brands and models of adapters that are not listed on the compatibility list. I am using a D Link 140 and it is working great. Streaming ISO files from my desktop via a USB External hard drive using a Dlink 315 G router. Hope this help as I just got mine for Christmas as well. Best advice is research your device before you buy and continue after. It helps with the learning curve.


#3

extrememc Please accept my apology for the long delay in answering your reply to to my original post, as today is the first time I have logged in to the forum after finding your email during a cleanup of my overful inbox. To answer your question, yes, I meant a USB Wireless Adapter. Thanks kindly for your suggestions. My solution was to buy a D-Link Wireless Access Point (model DAP-1150) and set it to ‘client mode’ via a switch on the back. This solution, whilst more expensive than a compatible USB Wireless Adapter, has worked faultlessly. Off topic, I am still having problems with my WD TV Live Media Player randomly locking up during media streaming, requiring me to power cycle the unit. This was not fixed with a firmware upgrade, but I need to recheck this, since I haven’t used the unit is several months.