USB Stick No media files found. Have to factory reset every time for usb stick to work. new to hub

Hi guys. I just bought my first hub a little over a week  ago. I don’t have it connected to the internet. I bought a 16gb Transcend USB stick to put my movies on and watch on the Hub. I had no problems at first. I watched them right off of the USB stick. Then I transferred some to the internal hard drive. This was fine for the first five days or so.

Anyways. The last three days when I put my USB stick in it says do you want to sync the usb folder I hit cancel and the USB files never show up.  When I choose the USB stick it says “there is no media in the current folder.” If I reset the factory settings it works fine but only once. I have to do it every time for the USB stick to work. :frowning:  This has happened at least 15 times in a row.

Also if I put the USB stick in  and chose to sync  the files as soon as I put the usb in it will transfer them to the internal hard drive each time without a problem. 

So again…

When I plug in the USB drive in the WD TV hub it recognizes the usb disk but says the “no media files found”

When I go to disk information , it recognizes the usb disk and all the space information (ex: 7gb occupied, 9 gb free space)

I’m using the firmware that came with it. 2.03.24 and I hit eject every time before I remove the usb from the hub.

Also… The hub will never recognize the usb stick if I start the hub with the usb inserted.

Please help. I have no internet connection and this is the only way I can watch movies. I don’t want to have paid 200 dollars for a paper weight that worked for a week. Thanks. 

I searched a ton but could only find one other post like mine and he didn’t get a solution. 

also it was a transcend 16gb usb stick that i reformatted from fat32 to ntfs so i could get files over 4 gigs on it. 

Update the firmware if you can ?

At least with the latest firmware you can rescan things and it may save you having to reset it every time.

They have improved a lot of things with the latest one.

@ shonuff

also it was a transcend 16gb usb stick that i reformatted from fat32 to ntfs so i could get files over 4 gigs on it.

did you delete all partitions on the stick before formatting ?  Some Usb Sticks have U3 partitions.

Also just checking out a website for transcend usb sticks…

http://ec.transcendusa.com/product/ItemDetail.asp?ItemID=TS16GJF2A

Features on USB sticks like this can cause problems…

ie. Secret-Zip Function compresses and/or Password protects saved files using AES Encryption.
    
Boot-Up Function makes the JetFlash 2A a bootable device.

this was the usb stick. There were no files/partitions or anything on it. thanks for looking…

http://ec.transcendusa.com/product/ItemDetail.asp?ItemID=TS16GJF700

I just want this to work as I just bought the thing. It worked fine for a week. And works once everytime i do a factory reset.

I’ve never changed the firmware since i just bought it and i’m a bit scared to after reading the horror stories on this forum. Do you think that could help?

Does anyone else have any ideas? If i can’t watch of the usb stick this thing is useless to me. :frowning:

Well I think if you have to do a system reset every time. And you can’t get the stick to work, a firmware upgrade is a good option.

Hi guys another quick question…

I just noticed that when I do the safely remove hardware from usb stick when it’s in my computer the light on the USB goes totally black and shuts off. This is with the USB stick still in the computer. I haven’t pulled it out.

When I hit eject on the hub the usb tip stays blue it just doesn’t flicker or flash or anything.

When you guys hit eject on your usb stick does it goes completely off? Again this is with the USB still in the HUB. I haven’t pulled it out.

Thanks.

Lights go out on my Flashdrives (sticks) and HDD’s when i remove them.

Not saying this is the cause… but is your “SYNC From USB Storage”   option in SETUP > OPERATION turned 'OFF’

i always turn this Setting to “OFF”