USB Share broken after upgrade to Firmware 1.05.36 [Solved]


Problem after upgrade to Firmware 1.05.36.  When connecting USB disk there no share created for the newly connected disk. The result is:

  1. Broken functionality backup to USB disk
  2. Broken functionality restore from USB disk

It worked OK before thefirmware upgrade (I have been using this a lot). I have checked through ssh login: the disk mounts ok.

Please fix!!

Odd, it’s working on mine just fine (I have two USB drives hanging off my MCM, both with automatic shares). What type of drives are they?

The only thing I’ve noticed is that Webdav doesn’t work for such drives (if you set it then select a different share and then go back to the USB one, Webdav is no longer selected). I raised that as a bug with WD this morning.

Don’t understand either. It worked like a charm before the upgrade. It is a 500GB NTFS disk. Point is, with ssh I can can go there, copy files etc., but the share just isn’t created.

Question: what exactly do you mean with  “both with automatic shares”.  The shares are automatically created? i.e. what I am refering to?   I can’t remember there a setting that coudl enable/dsibale that . . . 

Yes, that’s exactly what I mean - the shares that are automatically created when you insert the drive (ie the functionality you seem to have lost). There’s no setting to enable/disable that, at least that I know of. It should just always automatically do it.

The shares themselves are just links in the /shares folder, to the relevant mount folder if what I can see on my MCM via SSH is what I think it is. You may be able to manually make the links yourself via the command prompt as a work-around. Please note that I haven’t tried this myself, as my one works.

But what I would do is try and install the firmware image again over the top of your current one. You can download it manually from this page and then install it via the dashboard using Settings > Firmware Update > Manual Update. There should be a button there that you press and point it to the firmware image file you downloaded and stored on your local machine. If the button isn’t there, try a different browser (I find on my Windows machine it doesn’t appear under Chrome, I have to use IE for that job).

It turned out to be a problem with the USB disk itself. I tried another disk and that worked OK. So I focused on the drive that showed the problem.

  • I did a CHKDSK on Windows. Nothing was found. Problem still existed
  • I did a CHKDSK on Windows scanning for bad sectors. Nothing was found. Problem stil existed
  • I reformatted the USB drive on Windows and finally the probplem was gone.

Absolutely weird, because the USB disk mounted perfectly, could do al sorts of things with it using SSHD, but the share was never created. Only after I reformatted the disk.

The only thing I can imagine is the following:  I made a NAS to USB backup using this disk before doing the Firmware upgrade (a good habit!). I left the disk connected to the USB port. Installed the new Firmware. Rebooted the NAS and then the problem showed up. Seemingly the Firmware upgrade created a glitch on the filesystem that it could not handle.

Anyway, I am puzzled. So, mothers keep your children at home and disconnect your disk before doing a firmware upgrade

Solved (well kind of)