USB Recognition on Windows 8.1

HI all,

        I am having trouble using my WD drive on my new laptop. Its an ASUS Zenbook.The USB drives work fine. I can print from them, run an iPod, charge an android device etc. But i cant get the external HD to work. The light on the drive works, the platters are spinning, but it is not recognizable anywhere on the computer. Not in disk management, not in device management, not in Devices/Printers, explorer ?? I have installed the SES driver, I believe it is not required for recognition but I did it anyway. The last laptop was running Windows 7. I used that laptop to update the firmware for the external and it worked fine on the old laptop. I can access the drive on the old laptop, without any problems. All of the required drivers can be seen in the system32/.../ etc. for the usb on the new computer ! All wondows updates have been completed and this is what I assumed the external used as a driver for the usb ?? When I watch the device manager and insert the HD, nothing ? I am at a loss and was hoping that one of you may have seen this problem before on windows 8.1. I'm not a genius with computers, but I think I have tried every bit of troubleshooting that I can think of. Surely there would be enough power through the USB 3.0 ports ?? I would appreciate some sort of guidance. Up until now, the drive has been brilliant. Thanks guys.




Welcome to the Community.

Maybe you should try contacting WD’s Technical Support about this. You can do so either by phone or email.

To Contact WD for Technical Support

Support by Country

thanks for that. i did call and speak to them. no help. drivers are on the laptop so that is there responsibility !! any ideas at all. im open to any suggestions.