USB My Book Not Recognized - reporting 0K available

The docking station was a cheap no name one from Amazon. Model #: XWL-668U3.

Some more adventures on trying to figure out the USB issues I have with two of my USB drives (both USB 3.0). Ended up bricking the My Cloud during these adventures which then lead to another whole series of adventures because the update from v3.04.01-230 to v4x firmware caused the dashboard to vanish and never load (oh joy was that fun and time consuming to fix that problem through trial and error).

In the travels of fixing the bricked drive I found that with v3.04.01-230 my Toshiba USB 3.0 1T USB drive loads/mounts correctly in read/write mode. Once the My Cloud was updated to v04.04.01-112, the Toshiba USB 3.0 1T USB drive while it now mounts (didn’t mount at all prior to bicking the drive with v04.04.01-112) it mounts to read only mode for some reason. Better but still not where it should be with full read/write access to the drive. A snippet of the dmesg that shows the firmware (or the hardware) is still having trouble accessing the drive.

[ 6466.340805] hub 2-0:1.0: state 7 ports 1 chg 0000 evt 0002
[ 6466.346360] hub 2-0:1.0: port 1, status 0203, change 0001, 5.0 Gb/s
[ 6466.508947] hub 2-0:1.0: debounce: port 1: total 100ms stable 100ms status 0x203
[ 6466.629002] usb 2-1: new SuperSpeed USB device number 2 using xhci-hcd
[ 6466.649301] usb 2-1: skipped 1 descriptor after endpoint
[ 6466.654649] usb 2-1: skipped 1 descriptor after endpoint
[ 6466.660454] usb 2-1: default language 0x0409
[ 6466.665109] usb 2-1: udev 2, busnum 2, minor = 129
[ 6466.669963] usb 2-1: New USB device found, idVendor=0480, idProduct=a006
[ 6466.676705] usb 2-1: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[ 6466.683911] usb 2-1: Product: External USB 3.0
[ 6466.688384] usb 2-1: Manufacturer: Toshiba
[ 6466.692518] usb 2-1: SerialNumber: 2011111316674
[ 6466.697450] usb 2-1: usb_probe_device
[ 6466.701174] usb 2-1: configuration #1 chosen from 1 choice
[ 6466.706806] usb 2-1: Successful Endpoint Configure command
[ 6466.712449] usb 2-1: adding 2-1:1.0 (config #1, interface 0)
[ 6466.718485] usb-storage 2-1:1.0: usb_probe_interface
[ 6466.723678] usb-storage 2-1:1.0: usb_probe_interface - got id
[ 6466.730485] scsi2 : usb-storage 2-1:1.0
[ 6466.734913] /files/sq_kernel/linux/drivers/usb/core/inode.c: creating file '002'
[ 6472.037292] scsi 2:0:0:0: Direct-Access     TOSHIBA  External USB 3.0 0001 PQ: 0 ANSI: 6
[ 6472.046266] sd 2:0:0:0: Attached scsi generic sg1 type 0
[ 6472.053762] sd 2:0:0:0: [sdb] 1953525168 512-byte logical blocks: (1.00 TB/931 GiB)
[ 6472.063137] sd 2:0:0:0: [sdb] Write Protect is off
[ 6472.067966] sd 2:0:0:0: [sdb] Mode Sense: 33 00 00 08
[ 6472.074047] sd 2:0:0:0: [sdb] Write cache: disabled, read cache: enabled, doesn't support DPO or FUA
[ 6472.109831]  sdb: sdb1
[ 6472.113982] sd 2:0:0:0: [sdb] Attached SCSI disk
[ 6474.492376] ufsd: "mount" (sdb1): RAW NTFS volume: Filesystem size 931.51 Gb > volume size 931.51 Gb. Mount in read-only
[ 6475.342632] ufsd: "mount" (sdb1): is mounted as NTFS (without journal)
[ 6475.349238] ufsd: No write support. Marking filesystem read-only
[ 6510.129081] usb 2-1: reset SuperSpeed USB device number 2 using xhci-hcd
[ 6510.149371] xhci-hcd xhci-hcd: xHCI xhci_drop_endpoint called with disabled ep ce931480
[ 6510.157686] xhci-hcd xhci-hcd: xHCI xhci_drop_endpoint called with disabled ep ce9314ac
[ 6510.166373] usb 2-1: Successful Endpoint Configure command
[ 6527.509065] usb 2-1: reset SuperSpeed USB device number 2 using xhci-hcd
[ 6527.529422] xhci-hcd xhci-hcd: xHCI xhci_drop_endpoint called with disabled ep ce931480
[ 6527.537478] xhci-hcd xhci-hcd: xHCI xhci_drop_endpoint called with disabled ep ce9314ac
[ 6527.546427] usb 2-1: Successful Endpoint Configure command
[ 6529.849078] usb 2-1: reset SuperSpeed USB device number 2 using xhci-hcd
[ 6529.869362] xhci-hcd xhci-hcd: xHCI xhci_drop_endpoint called with disabled ep ce931480
[ 6529.878190] xhci-hcd xhci-hcd: xHCI xhci_drop_endpoint called with disabled ep ce9314ac
[ 6529.886524] usb 2-1: Successful Endpoint Configure command
[ 6565.709064] usb 2-1: reset SuperSpeed USB device number 2 using xhci-hcd
[ 6565.729416] xhci-hcd xhci-hcd: xHCI xhci_drop_endpoint called with disabled ep ce931480
[ 6565.737478] xhci-hcd xhci-hcd: xHCI xhci_drop_endpoint called with disabled ep ce9314ac
[ 6565.745649] usb 2-1: Successful Endpoint Configure command
[ 6577.439089] usb 2-1: reset SuperSpeed USB device number 2 using xhci-hcd
[ 6577.459596] xhci-hcd xhci-hcd: xHCI xhci_drop_endpoint called with disabled ep ce931480
[ 6577.467779] xhci-hcd xhci-hcd: xHCI xhci_drop_endpoint called with disabled ep ce9314ac
[ 6577.475948] usb 2-1: Successful Endpoint Configure command
[ 6579.389067] usb 2-1: reset SuperSpeed USB device number 2 using xhci-hcd
[ 6579.409426] xhci-hcd xhci-hcd: xHCI xhci_drop_endpoint called with disabled ep ce931480
[ 6579.417483] xhci-hcd xhci-hcd: xHCI xhci_drop_endpoint called with disabled ep ce9314ac
[ 6579.426051] usb 2-1: Successful Endpoint Configure command

Edit to add: Toshiba drive reports no errors in Windows and mounts with full read/write access on several Windows PC’s.

@Bill_S, I don’t know how many users that WD needs in order to prove that there is a bug. Hopefully this problem has made it to the next fix-it patch that is coming out soon as several of us have reverted back to an older FW in order to attach a USB drive.

You should pass along all the findings above by Benor as he has spent days meticulously testing and bricking his cloud just for your benefit of tracing down your bug.

It would be appreciated if you reply with an acknowledgement as well as “this has been passed on to tech support” and perhaps a mandate of when a fix or solution is available.

Appreciate your presence .

We’re already getting in touch with @Bennor to go over the issue. And, yes, it’s going to be looked into.

Bricking the drive was all on me. Was rooting around via SSH looking at things, I decided to downgrade to see if the that would fix the USB read issue with my two 1T external USB 3 drives and that’s where things went south and I bicked the 250GB drive I have in the My Cloud (formerly 4T) enclosure.

My problem is trying to figure out if it is the two 1T USB drives that are at fault or the WD My Cloud enclosure that is at fault. Right now outside of a few of us its not certain that there is a wide spread problem with the USB port other than speed copying issues discussed in many other threads. Its hard to tell if certain brands/models/capacity external USB drives have issues or if it is the hardware of the My Cloud or something with the firmware. Or was it something with the unbricking process I used that is causing my problems.

If someone can point out which logs should be posted to help with this troubleshooting I’ll post them.

I have mounted a 4TB My Book to the My Cloud using version 112 firmware. I also have mounted a 16GB memory stick. No problems with either. I did notice that the wdnotifierd process is not involved with the mounting of either USB device. I even copied a photo to my drive and wdnotifierd was again not involved. Not sure what this process is used for.


@Bill_S, much thanks on the prompt reply. It was so quiet here that I was worried that you left for a much needed holiday after last week. :stuck_out_tongue:

@Bennor, I would recommend that you RMA the bricked drive when they make the offer :stuck_out_tongue: While it is true that the Cloud has a preferential affinity to WD products as well as a speed difference (Vantec Raid had half the speed of my WD), both of my drives are WDs’ a 1TB Passport and a 4TB My Book, so the problem on OS3 is apparently non-discriminatory. Also occurred on both Clouds; one upgraded from 3.04 and one upgraded from 4.xx. Both reported 0K and Share not created.

@Bennor : new note. Did a speed test and there is a speed increase from 75MB/s reads to 90MB/s reads OS3 on a WD 4TB My Book, 45MB/s writes stayed about the same.

@rac8006, I believe the USB drive is mounted or dismounted regardless of the running of WDNotifierd, but in order for the Dashboard to show mounted or dismounted you need to start up WDNotifierd. I normally have the service stopped.

The fun part was when I started both WDNotifierd and Wddispatcherd on FW 3.04 with a USB drive 4TB full of unscanned data, the Cloud slowly got into a locked state and by slowly, I could feel the sluggishness as I typed… and soon I could not even kill a service as those two services locked.

Thus wdnotifier is started when I need to unmount or mount a USB drive and for the status to appear on the dashboard. Otherwise I don’t get notified :stuck_out_tongue:
Not sure what the wddispatcher does, but it probably dispatches a requested service.

I’m working on it… :sunglasses:


Good News!!

Due to the recent discovery that my Cloud App does not have remote access to my downgraded FW3.04 Cloud, I had to take the chance of upgrading it back to 4.04.01-112. This was one of my reason that I bought my 3rd Cloud, just in case one goes south.

After not breathing for 30 minutes, my cloud is now back on the most recent version and, most importantly, it mounted my USB “My Book” without any problems.

So I thought I let you know that you have one less user yelling about this problem. Sorry @Bennor you are now officially alone with this problem. I think there was one other but I think WD RMAed him.

So I’m back to all my services stopped on all 3 clouds and they all seem to run perfectly (knock on wood). Some minor sleep issues of random wakes but I’ll live through it.

Still debating on tearing my clouds apart for the 4TB Reds to put in a QNap, but for now… thats $400 still in my pockets.

If anyone else still has this problem, please add your voice to this post.

edit: what did I do to make this work? I have no idea but this particular Cloud went through an upgrade to OS3, USB drive wouldn’t mount, so I downgraded it back to 3.04 followed by a 40 second reset and now an upgrade back to OS3. So it could be anything.

@Ralphael, was your My Cloud that you upgraded to latest firmware and is now mounting your external USB drive properly in stock mode? In other words was it a My Cloud that did not have any services modified or stopped via SSH when upgraded to latest firmware and then USB drive added?

Was contacted over the weekend by WD support and have emailed them a system log report generated by the Dashboard. Haven’t heard anything since sending the logs on Sunday night. The log sent included four external USB devices, two which didn’t mount properly (both USB 3) and didn’t show any drive contents, and two (both non USB 3) which did mount and display drive contents properly.

I always have all the mean services stopped before and after an upgrade otherwise they start messing with my drive like the new cloud with my USB passport that locks the whole system.

I don’t recall doing anything different this time around. In fact the other Cloud that was upgraded to OS 3 that had exhibited the no mount USB symptoms started to mount my USB drives with no problems. The one difference on the other one was that I did a shut down, removed from shelf, then rebooted it up on my desk. Then all my USB WD Passport, My Books (3 of them now) all mounted without a hitch.

This last one that I had downgraded even has the Public folder set to private; in fact it is still that way at the moment. Private I think.

One thing to note though, all my services that I stop, they are only temporary. They restart normally on reboot. The reason that I don’t make them permanent was the 3.04 upgrade of which I did stop the two scans permanently using

update-rc.d wdphotodbmergerd disable
update-rc.d wdmcserverd disable

That was my first scary update in which I was locked out of SSH until I did a 40 second reset of which I attributed to the permanent service removal (which wasn’t true). Nevertheless I vowed that any upgrades will be as close to stock as possible, with the services stopped during the upgrade otherwise they will overload the CPU with both scanning and upgrading at the same time.

To answer your question… yes a bunch of services were stopped during the upgrade, but not the permanent kind. Even wdnotifierd was turned off as well as wddispatcherd.

Did you turn off those services prior to inserting the external USB drive on the latest firmware?

Its entirely possible its just happens the two USB 3 drives I have are possibly incompatible with the My Cloud. Or its possible some combination of settings or running services are causing problems that manifest themselves when certain USB drives are used. Or there is something wrong with the unbricking + firmware upgrading steps that causes this (and other) issue(s) to surface.

Got a somewhat (I assume) canned response back after my prior post above from WD Support:

The appropriate engineering team is aware and working on the issue with the WD My Cloud. Once a fix is found, it will be provided in the form of a firmware release. As with any update, that has to go through a complete regression test before it can be released to ensure that the change has not compromised any other feature; therefore, we do not have a release date.

Actually yes… so bear with me on the long winded stretch of typing…

The first time I installed OS3 I only turned off only two services at the beginning

/etc/init.d/wdmcserverd stop
/etc/init.d/wdphotodbmergerd stop

Then inserted the USB drives of which both were giving out errors…

Then I moved one of my OS3 device from the shelf to my desktop (doing a shutdown and power up).

This time after I powered it up… I issued my script…

/etc/init.d/nfs-kernel-server stop
/etc/init.d/nfs-common stop
/etc/init.d/upnp_nas stop
/etc/init.d/mDNSResponder stop
/etc/init.d/wdphotodbmergerd stop
/etc/init.d/wdnotifierd stop
/etc/init.d/wdmcserverd stop
/etc/init.d/wddispatcherd stop

of course wddispatcherd is no longer a part of OS3.

Then I inserted the USB drive.
/etc/init.d/wdnotifierd start

so that the USB drive gets updated on the Dashboard page…

Then I stopped it after it gets mounted.
/etc/init.d/wdnotifierd stop

This was the first time that I managed to mount my USB drive on OS3.

I figure it had to do with possibly the shutdown and power up (much like a small reset). Also I notice that in one of the boot up scripts they issue a chmod on all the Public folders to make public share to fix the permission problems with public.

Anyways, I run the above stop scripts on all my OS3 drives now. The reason that I don’t leave the other services running as you saw on my “Absolutely terrible! Absolutely Unusable!” post the services really play havoc on your drives if you are not careful.

I’m pretty sure one of the services are causing trouble. Also, I noticed back with 3.04, if you wait about 5 minutes after the startup, inserting a USB drive doesn’t cause a lock up. This may be the same effect that we might be seeing here in OS 3.

If however, you stop wdnotifierd and wddispatcherd in 3.04 and restart them after inserting the USB drive, then stop them afterwards, you stop the lockup.

Thus the carry-over… stopping, starting and stopping wdnotifierd; which I think all it does is update the dashboard.


Tried stopping those services on my end and the USB drive still doesn’t mount properly. When getting to the point of inserting the USB drive and before issuing the /etc/init.d/wdnotifierd start command the Dashboard indicates the following and nothing mounts. Going to continue to do some troubleshooting from time to time to see what combination of factors will get this external drive to work properly as it does under v3 firmware.

USB Device Details
USB Device Name Toshiba External USB 3.0
Manufacturer Toshiba
Model External USB 3.0
Serial Number 2011111316674
Firmware Version 0.01
Size 0 KB

Unable to create share
A share could not be created on a USB device (vendor: Toshiba, model: External USB 3.0, serial number: 2011111316674, file system: ntfs, label: TOSHIBA_EXT, share name: TOSHIBA_EXT).
Wednesday, November 11, 2015 1:04:47 PM Code 1122

Here is something that you can try. There is a database in /var/local/autoMount/autoMount.db. It seems
to contains a list of devices mounted on the My Cloud. I’m not real familiar with sql. But you can
do the following to see what is in the file.
sqlite3 /var/local/autoMount/autoMount
sqlite>select * from devices;

I’ve also used a program called sqlite Database Browser.exe. Just have to copy the autoMount.db to the public folder so windows can see it.

PS This database seems to remember what devices have been plugged in.

I never tried before but I tried my USB 3.0 docking station which wouldn’t mount. I used WinSCP with its editor to look at that file. A few unreadable graphic characters and some readable text. One line was “JMicron USB 3.0 SATA Bridge falseunsupporteddun” which was repeated a few times in that same line. I’d post the whole thing but there wasn’t a way to save the file to another location.

@ rac8006, Initial post edited. Corrected SSH SqlLite3 results. The first entry for Toshiba is the problematic drive that doesn’t get mounted properly with the My Cloud. The Prolific Technology entry is for a Prolific Technology (generic branded) enclosure that has trouble mounting from time to time. Most other devices mount and are accessed without issue.

WDMyCloud:~# sqlite3 /var/local/autoMount/autoMount.db
SQLite version 2013-09-03 17:11:13
Enter ".help" for instructions
Enter SQL statements terminated with a ";"
sqlite> select * from devices;
0|1|Toshiba|External USB 3.0|2011111316674|0.01|false|unsupported|unsupported|||unsupported|0480|a006|1|3.0|5000|1447258870.6815|||
0|3|Prolific Technology Inc.|USB-SATA Bridge|PROLIFICMP000000002|1.00|false|unsupported|unsupported|||unsupported|067b|2733|1|3.0|5000|1447035032.84039|||
0|4|Prolific Technology Inc.|2733||1.00|false|unsupported|unsupported|||unsupported|067b|2733|1|3.0|5000|1446700337.77688|||
0|5|05e3|USB TO IDE||0.33|false|unsupported|unsupported|||unsupported|05e3|0702|1|2.0|480|1446708272.68205|||
0|7||USB DISK 2.0|07460E140861|0.50|false|unsupported|unsupported|||unsupported|0d7d|1300|1|2.0|480|1446708355.6015|||
0|8|Prolific Technology Inc.|USB-SATA Bridge||1.00|false|unsupported|unsupported|||unsupported|067b|2733|1|3.0|5000|1447035064.51089|||
0|9|Western Digital|External HDD|57442D5758485A3038363338383632|0.175|false|unsupported|unsupported|||unsupported|1058|0705|1|2.0|480|1447125872.05536|||

I took a quick look at the autoMount.db file with SQLiteDatabaseBrowser program and it is showing information for the Devices table. For the one Toshiba USB hard drive that doesn’t mount, this is what it shows:

connected: 0
handle: 1
vendor: Toshiba
model: External USB 3.0
serial_number: 2011111316674
revision: 0.01
ptp: FALSE
smart_status: unsupported
lock_state: unsupported
standby_timer: unsupported
vendor_id: 480
product_id: a006
usb_port: 1
usb_version: 3
usb_speed: 5000
timestamp: 1447258870.6815

Not sure what this information means. But the MC does see your USB device. Are there any messages in the logs? What I did was go to the /var/log directory. Then did a grep USB *. This
will show any log that has entries for USB devices. Then look for any mention of your Toshiba device.


I think I’ve posted some info from the logs before. Basically the My Cloud sees the drive and the space on the drive but then indicates its read only then throws a “fill_super failed to mount sdb1” error in the message log an kern log. WD has the logs so hopefully they can make heads or tails of why is happening and suggest a reason, fix or workaround.

Message log:
notice kernel:[ 4751.541534] ufsd: Boot's size of Volume is greater then allowed in RWBlock!!
notice kernel:[ 4751.548624] ufsd: Boot is accepted as NTFS of size 931.51 Gb
notice kernel:[ 4751.554333] ufsd: RAW NTFS volume: Filesystem size 931.51 Gb > volume size 931.51 Gb. Mount in read-only
notice kernel:[ 4751.627139] ufsd:fill_super failed to mount sdb1: "" ->-22

Kern log: 
err kernel:[11515.328604] ufsd: unable to replay native journal on "sdb1" 
notice kernel:[11515.334213] ufsd:fill_super failed to mount sdb1: "" ->-22

Edit to add: I should note this Toshiba drive checks out normal with no errors in Windows.

It almost looks like the drive was not ejected properly. Why is it trying to run the journal?