USB mount HD is not writable

Hi all, I have been using the WDTV Live Hub successfully for about 4 months now and I’ve always had the 1gb usb HD connected and working well.

I usually access the USB HD via the network and write files without issue.

But now, for some reason? the USB HD is not writable to wither my Macbook or the WDTV Live Hub. If I try to copy a file from the internal HD on the WDTV Live Hub to the USB HD I get an error saying the drive is not writable.

When I try to access it via my Macbook I get the same error basically. The drive is not writable.

This happened once before and I deleted the hidden files on the internal HD of the WDTV Live Hub. But, I’ve tried that again and it just hasn’t worked.

So, I’m stumped. Can anyone offer any help please??

One more thing. If I hook up the usb HD to my Macbook via the USB I can write to it no problems. So, it’s a mystery for me.


have you tried formatting the the usb drive

No way! I have a lifetime of videos on that hd. I’d sell the WDTV Live Hub before that.

The problem isn’t with the hd as I can plug it into my computer and every folder is writable. It seems to only be with the WDTV Live Hiub

do you have another drive to temporary store your stuff on,

Since it is very important data, you best invest in a backup drive or you will loose your valuable video. It isn’t a matter of IF a hard drive will fail, it’s a matter of WHEN will it fail.

1 Like

Well, it’s now October and I STILL have the problem. The HD is OK although after I leave it plugged into the WDTV Live Hub for a week or so and plug it back into my computer I have to repair the permissions as the computer tells me it has permission errors.

I fix the HD and have tested it without issue for a week on two computers I have without issue then plug it back into the WDTV Live Hub and all the permissions are non writable.

The issue is with the WDTV Live Hub not the HD. I don’t suppose anyone has any ideas of how to fix it??