USB Mass Storage Issue

Re: My Passport Wireless

When I try a USB connection to my Windows XP PC (not necessarily expecting any recognition) the PC actually detects it - no sign of it though, except for Disk Management where it shows as a ‘Healthy (GPT Protected Partition)’. Strange, it was exFAT when it worked on Windows 8 (as it should be) – so why not with Windows XP, the drive hasn’t been altered?

Nevertheless, now it shows an error with a USB connection on Windows 8 and I’m prompted to scan (Error Check) it. After doing so all seems ok again – unless I connect to Windows XP again and it’s a case of déjà vu!

As far as I can see, it’s the .wdcache folder causing the issue (‘Location is not available’, ‘F:.wdcache is not accessible’, ‘The file or directory is corrupted and unreadable’).

What’s going on, any ideas – is there a workaround that prevents this but enables it’s use with Windows XP?

As a side issue; twice I’ve tried registering my device with Western Digital but have yet to receive an acknowledgement email.

As you were, I’ve sorted it myself – works fine on both XP and Win8 now.

Still no registration acknowledgement from WD though – guess one can’t have everything?

Microsoft Windows XP does not support the exFAT file system without a dedicated, optional update.

https://support.microsoft.com/en-us/kb/955704

The exFAT file system works fine on Windows XP (I have a number of these drives running ok on XP). It’s the GUID Partition Table (GPT) that isn’t supported - so I converted it to an Master Boot Record (MBR) - works fine now, on both Windows XP and Windows 8.