so i scoured the forum last night trying to find an answer before i posted a question and did see someone with the exact same issue as me, but his solution didn’t work for me.

a little background…i have a wd tv live media player. i have a windows 8.1 laptop. the media player itself is 2 years old. i HAVE NOT updated the firmware on the device since i got it as i had issues getting the device to recognize the shares i had setup. at the time i initially got the device 2 years ago i had a win7 laptop. i was on the phone with technical support for about an hour and the guy couldn’t figure out why the updated firmware wouldn’t recognize the shares when the older version of the firmware could so he told me just to reset the firmware to the previous version. i have never updated because of that reason. everything still works fine with that version from 2 years ago even on a new win8.1 laptop.

now fast forward to now…i have 2 external HD’s. one is a 4TB and one is a 3TB. one is dedicated to Movies and one is dedicated to TVShows. plugged in directly to the win8.1 laptop they work fine. the wd tv live media player is able to see the shares and plays pretty much all my content except for HEVC encoded files. i bought a USB Hub yesterday as i only have 3 USB ports on the laptop itself so i was trying to consolidate my externals to the USB Hub. when plugged into the hub however the wd tv live isn’t able to see the shares. after investigating a little bit i realized once plugged into the USB Hub for some reason the “TVShows” folder wasn’t shared. so i went through the process of sharing it (again) with the same settings as i did for when it was connected directly to the laptop itself. wd tv live media player still doesn’t see them. when plugged back into the computer directly, the wd tv live media player not only sees my original shares, but also the 2nd share i setup when it was connected to the USB Hub. it plays files fine from the 2nd share created for the hub so i know the permissions are correct.

long story short i was on the phone with technical support this morning and was told the wd tv live media player will not see shares when the externals are plugged into a hub. i don’t know why plugging them into a hub makes a difference but it’s frustrating to say the least. if anyone has any solutions or different information than i was given over the phone i’d love to hear it, but figured i’d post this for anyone who experienced similar issues so they don’t waste an evening trying to figure this out.

sorry to reply to my own topic, but after trying some more fiddling and this topic from this user i was finally able to get it to work.

for anyone who doesn’t have the IRPStackSize value just go his route and create it, but set the value to 20. again i have a windows 8.1 OS and that worked for me. don’t know if it’s different based on OS version, but like that user said just continue trying incrementally until your WD product recognizes it. you don’t even need to recreate the share once plugged into your hub like i initially did.

not knocking the woman i spoke to on the phone from tech support, but she was adamant from the beginning this product wouldn’t recognize shares if plugged into a hub. kind of makes you wonder what western digital is doing having people on tech support if they can’t figure out their own issues. big thanks to pallas from the original thread where i found the solution. hope this helps anyone else who encounters this probem.

Hello and welcome to the community,

Thank you for sharing the solution to you first post. I am sure this will help other users.

1 Like