USB HDD keeps getting "lost" on my WDTV Live Streaming

Hello all, hoping someone out there knows a fix for this problem I am having.

I purchased a Live Streaming about 2 months ago, and have loved it.  However, one problem intermittently shows up.  I have a powered USB HDD connected to it, with all of our music, movies, etc.  Normally works great: the first time I plugged it in, it took a while to index everything, but no big deal.

I always put the device into Standby mode when not using it.  (This way, even with it off, the hard drive was still available on the network in case I wanted to stream from it to my laptop.)  Now, every once in a while - as in, every couple of days - the drive becomes inaccessible to streaming.  So, I turn on the WDTV, and it does not recognize the drive is there!  Then, I wait about 5 minutes, an the light starts blinking (like it is reindexing) for a few minutes, and then the drive is back and everything is fine again, all files & folders available.

I fully expected the HDD to go to sleep when the WDTV was in Standby, and to have a wake-up delay if I tried to stream on the network from it.  However, in these cases - if I don’t go to the WDTV, turn it on, and wait about 5 minutes, it will never wake up.

This is intermittent, however; sometimes I will leave the device for over 24 hours without using it, and then access the hard drive without a problem.

I’ve tried deleting the .wdtv folder and letting it reindex completely, no luck.  

Does anyone know what’s going on?  Or possibly have a suggestion?  I am thinking about leaving the WDTV on all the time and see if that fixes it, but I don’t want to just have a “workaround” if there is a real solution out there.

Thank you!

Be sure to install the latest firmware update available.

For what it’s worth, I’ve had the exact same problem since we purchased ours around the same time.  The reindexing is really frustrating as it takes so much time. 

And I’m running the latest firmware and have been since it was released.

I’ve had this happen to me once so far. I have the latest firmware already. Hopefully it won’t reoccur…

Mine has started doing this too…

All is well, media library working, networked, running smoothly when all of a sudden, whoosh…media library is lost, and spends hours rescanning…

It has done this every day for about a week, and it seems to take hours to rescan all the media…it’s getting very annoying.

Note, no media is being streamed TO the SMP, though I sometimes do transfer files to the SMP wirelessly. My media library is all attached via hard drive, 

I have the latest firmware. 


I have had many similar USB drive disappearing issues. My drive tends to get lost on power interruptions, restarts of the SMP, and sometimes after copying files to it over the network.  Connecting to my PC and runnng an error check/correction always fixes the problem until next time.  Errors are found and fixed on the disk.

After exhaustive Google searches some clues are evident in regards to different systems writing files to network connected USB drives running NTFS file systems.  For example, my PC is a 64 bit Windows system and the SMP likely writes as a 32 bit system (QNAP NAS forums similar issues reported).  The core problem with QNAP network storage systems is that file permissions get randomly screwed up. Most of the drive errors I get are in the index and security descriptor tables, along with a few others.

A related possible cause may be that my drive is formated with 4K size sectors and the SMP NTFS driver may be limited to 2k sectors. Who knows?

I used to play around with Freenas. They still do not recommend writing to NAS drives formated with NTFS as unexpected errors may occur to the file system. Their solution is to set NTFS drives as read only.  

I do not offer solutions, only point to some areas that maybe WD should investigate.


 My drive tends to get lost …after copying files to it over the network. 


This seems to be similar to what I am experiencing