USB Drive suddenly doesn't work

My WDTVLIVE Plus has been working fantastic for the last few months with no problems! I’ve been using a 1.5TB WD drive, which has been working great, but after copying files from it to another USB drive (via network) then unplugging and replugging the drive, the WD LIVE no longer recognizes the drive. I disconnected the drive and plugged it into a computer and all the files popped up perfectly. Anytime I plug the drive into the WDTV, the drive light and the USB indicator on the WDTV box just blink like car turn signals. Here are some things I’ve tried to fix the problem:

  1. Plugged the WD drive into another WDTVLIVE Plus (we have 2 of them): The second WDTV also just blinks but doesn’t recognize the drive.

  2. Tried with a friend’s non WD drive: Worked fine.

  3. Purchased a brand new 3TB WD drive and copied all files over: The brand new drive now exibits the same problem as the old drive! I understand the 2TB limitation was resolved in a recent firmware update and all our firmware is current. Unfortunately, I forgot to connect the drive to the WDTV before copying the files, to see if it popped up.

  4. Deleted the  .wd_tv folder from the drive (via computer) and plugged it back in to the WDTV: Issue still didn’t go away.

  5. Ran scandisk on drive: No errors found

I didn’t copy over any system folders to the new drive, only folder with movies in them. I am running firmware: 1.06.16_B on both boxes. What could be going on?

Thanks for your help!

Ok, so I plugged the WD USB drive into my computer and went through every folder and deleted all the .wd_tv folders. Then I plugged the drive back in to my WDTVLIVE box. A few minutes later, all the files popped back up and are working perfectly! Not sure if it’s because I deleted those folders or if I just wasn’t giving it enough time to read the drive. Maybe drives take longer to load with the new firmware, or maybe I just haven’t unplugged my hard drive in a long time and I’ve been filling up the space via network share.

I just tried this with the new 3TB drive, so I’ll try the same thing with the 1.5TB drive and see what happens.