USB drive share -- must it always be public?

I attached an external hard drive (formatted as NTFS) to my WD My Cloud EX4.  Just as the manual  promised, it shows up as a network share.

However it appears that this share is always public, accessible by *any* user with full read/write privileges.

Is there any way to change this? 

A public USB drive is useless to me.  I would love to use the USB backup feature, but not if any user can access it and muck with it.

I am I missing something?

Hello Tempos, you can also set the permissions to the USB connected share. Check page 42 of the manual for more information.

Hi, thanks for the reply!

In my dashboard, the USB drive is treated exactly like the “Public” share.  The permissions cannot be changed – every user has full access.  Even though I am loggin in as admin, the access options are grayed out in the dashboard (just like the “Public” folder).  I also cannot disable Media Serving, FTP, etc.

I have tried two USB drives.  One is a Seagate and the other is SimpleTech.  They are both formatted as NTFS.

I’ll post some screenshots below.  Notice that in the “User” menu, the USB shares don’t show up at all.  Is that a clue to the problem?

Just got off the phone with WD tech support.  They confirmed that in the older MyCloud products, USB shares can be made private, but in the EX4, USB shares *cannot* be made private.  Every user has full access.

The rep (who was very knowledgabe and helpful) put me on hold to speak to an engineer.  When he came back, he told me that they don’t know if they will work on this issue for futue software releases.

This is quite a disappointment.  A major reason I bought the EX4 was to use the USB backup feature.  Obviously I cannot back up private data to a public share, so now that feature is useless. 

what file system do you have on that usb drive? can you set file and folder security on the backup folder location on the usb drive and see if other users are able to navigate into the backup folders using the public share? so for example if backup folders had windows security settings set, can anyone still browse and access files via public share?

Hi, thanks for the suggestion.

The USB drives are NTFS.  I could try to manage permissions through Windows, but I think the share would still be publicly accessible through the moile apps, right?  I’ll try it out…

interesting points!  there are a more than few possibilities to test here.  unfortunately I do not have a usb disk connected to ex4 to test. will see what I can do.  iit would be interesting to see how mobile app would behave in this scenario.

Hi, I just got a EX4. I saw a message explaining new Ex4 cannot set share and permission on external USB. I am having same problem, but it is not true. When I first setup my Ex4, I use Raid 10 and I connect Seagate 4TB external drive. I formated over mac os x and I was allow to created a share folder inside external drive, I created 4 folders then I disconnect from Ex4 and connect to mac. I saw the folders there and start moving a a 3TB of data. Then I probably upgrade the firmware while I was copyng all that data, specially because took so long.  When I move it back with firmware updated I got error in file limit and I was not be able to create folders anymore.

I formate whole external drive and no way to create folder and set permission over external drive. My question is, anyone who have problems is running the new firmare is 08 or 25? 

I found old one over the internet , downgrade using dashboard and after I move all data from ex4 I will try full reset and see if the connected drivers show up in the share disk dropdown.

If anyone find fix, please post here.

I have to say that this is indeed a huge disapointment to me. I tried to set this up and was wondering why I could not make the external hard drive I connected private since it will house more files for me that other users do not see. WD needs to fix this.

Is there a way around this? Just like the person who started this post I want to purchase a 4TB external hard drive to start backing content up to it, but not if my users are able to see it and fiddle with the content on it. Plus I have stuff on there that only I can see and same with my users things that they see but not me but still needs to be backed up!

When I connected two drives(both WD 1 formatted to windows & mac and the other just to mac) they both remain public with it grayed out!

This missing functionality is a glaring omission and hopefully will be addressed soon.   My understanding is that it was an available feature on previous WD NAS products but was probably not implemented in the current version of the firmware due to the fact that this product was delivered to market well before it was ready and tested.  

Day one, this was a deal breaker for me if I wanted to share this device which I intended to do.  I requested that the feature be considered in a future firmware release under the idea forum.  Please go and vote for this feature if you feel as I do that it must be added for the whole sharing and cloud idea to make sense.  

Vote here

Yeah I originally bought the standard 4TB mycloud device and the functionality was there to make a USB connected share private. I know another feature that is not on the EX4 but on the standard is for the admin account to not see folders. I assigned certain individuals private shares just for them, and on the original Mycloud I could choose not to see them, but as the admin for this device I see everything 

This is the main reason I bought the EX4 (to be able to backup to an external WD My Book Essentials 2TB drive).  I spent and entire day trying to get this to work.  I thought something was wrong with the USB drive I have (which is also a WD), but here I find out that you can’t make it private!  Absolutely rediculous.  Please add this function along with the ability to schedule USB backups of the entire drive!

Well they need to fix the USB backup first. I know I was having issue with it actually performing the backup would start and then cancel itself after a few minutes of doing nothing.

I know that as I look to where I will be going in the next few years with cloud storage this is a feature that needs to be fixed if WD expect me to remain around once I hit the 16TB limit and rely on USB drive for more storage.

I am new on here and was searching the forum for the same problem I have with MyCloud.  I went to the Share’s tab and found the drive and just clicked on the “Public Access” tab and off it went.  No more public access!  Don’t know if the EX4 has the same functionality or if this is only a MyCloud (the non-EX4 version) feature.

No, on the EX4 you cannot delete the Public share, and you cannot modify the permissions of the Share.