USB drive disconnected from MyCloud


I have the following setup:

 - My Cloud 3TB (firmware updated a week ago)

 - My Book Essential 4TB (firmware updated yesterday)

 - A Windows laptop

My Cloud is connected to a local net. My Book is connected via USB to My Cloud. Both drives stand still next to each other on a shelf in a closed cabinet on another floor. There are two mappings on the laptop: “E:” for “My Cloud / Public” and “F:” for “My Cloud / MyBook”, which corresponds to My Book drive.

Now, quite often I loose the F: drive - reported disconnected by Windows. Looking at the web interface of My Cloud, I see usually two messages saying something like “USB drive unsafe removal”. By trial and error I figured out, that if I reboot My Cloud from that very Web interface, without ever physically going to the drives, “F:” drive is put back in service. Until next time. This happens roughly once a day or two.

Why one WD product doesn’t work with another WD product? Any recommendations on how to fix this?


Connect the drive to your computer through USB and disable the sleep timer on the My Book using the WD Smartware “Settings” tab

It is possible that this setting is causing the My book to go to sleep mode.

1 Like

I’ll have to install SmartWare first, so it’lll take some time.

Will this setting deteriorate the drive?

I set the sleep timer to Never, and now My Cloud cannot see My Book at all :-((

My Book is blinking blue, just as it should when connected, but My Cloud reports it has no USB device connected.

What can I do to diagnose this situation?


Connect your drive to the computer again using the USB port and try formatting it. Make sure you don’t have any important data on it since formatting it will delete everything from the drive. After formatting it run again WD Smartware and make sure the sleep timer is set to “never” and then connected to the My Cloud once again.

There is one more trick to do to have this working: one needs to NOT have the SmartWare running. Remove it from the startup applications, restart the My Cloud - and finally it is where it should be.