USB device not recognized


#1

“One of the USB devices attached to this computer has malfuntioned, and Windows does not recognize it.”

What the hell do i do? i can’t re-format it, because my PC cant even find it, ive backed up some things on it before, just went to put more on, and it doesnt work

Can anyone help?

Cheers


#2

Hi. I am an IT professional. I bought the 250 Gig Passport Elite to store all of my professional information and within 3 months it had stopped working. This was very serious issue for me. There was a “WD” recognised when I went to the Safely Remove Hardware icon in the bottom right of the taskbar but my drive was not recognised by windows - no matter what version of windows or what machine I tried to use. It seemed that the drive mechanism was not running - it ticked on startup as if trying to spin but then it was not recognised. I inquired about data-recovery options (around €1,000! being the best quote!). After searching online and trying various software backup and recovery options/downloads I simply straightened the USB cable and it worked again. I was advised to try everything from placing the drive in a zip-lock bag in the freezer through to all manner of driver advice. Two points: 1) If you have this issue ABSOLUTELY try using a different USB cable or (as worked for me) straightening the existing one. 2) Western Digital Customer Support - your customer service in this regard is appalling and when I do copy my information to my new non-WD drive I will strictly advise all who should ask to avoid your products like the plague. Also, you really should invest in a data-recovery service as when professionals such as myself put their trust in your products and they then fail (in my case with over 2 years of warranty remaining) you as the hardware provider MUST accept liability and cover costs with faulty product. Or at least offer an investigative service for the obvious issues such as I and many others have experienced.


#3

I do not know whether it was your solution or restarting my pc, defragging, and virus scanning, but it now works, i straightened the cable too. Thank you ever so much for the help :slight_smile:

Also. the autorun just got flagged up as a trojan, and firewall is trying to delete it, i think that may have been part of the problem

Thanks again