USB device not recognised


#1

Hi I just bought a new 500 gb my passport essential.When i am trying to access it it is giving error USB device not recognised and it malfunctioned.Could you please tel me what is the problem.I am able to see light and its spinning also just it is not able to load driver and malfunctioning.


#2

Try connecting the drive with the different USB cable and also try on the different USB port on the computer. The drivers are preloaded on the drive, so you don’t have to load them separately.

If the similar problem occurs, try on a different computer.


#3

I have an external drive for more 2 years and it was functioning properly, but today has just fallen from my desk and after that my computer couldn’t recognize it. I tried different USB ports and I unplugged it but still not working. What could I do? I really need the data and files in that drive??

Thanks


#4

I had the same problem, used the device for 1 1/2 years, it did not fall or anything… It just suddenly stopped working. I have hundreds of photos on it and I need them… The computer repair shop tells me I am most likely out of luck and that the pictures simply cannot be retrieved. I also posted a thread in which I  stated that I did change the USB cable and I did try a couple of different computers and that nothing worked. I haven’t had a response from anyone. So I guess I might as well face the facts…    :frowning:


#5

Hi,

if the data is really important there is still a chance, if only the case has been damaged and the harddrive itself is still working. in this case, just open the external case, take out the drive and plug it onto a PC direktly or using another case / adapter. but i am afraid the chance is higher, the disk itself is faulty… =(


#6

See http://community.wdc.com/t5/Desktop/Dropped-HD-Beeps-twice-at-me/m-p/25421#M1538