USB Device not recognised

I’ve been using my hard drive successfully for years.

I plugged in the drive, the same time as a USB stick to transfer the files, and the WD hard drive no longer works.
you can see it’s plugged in, but there is a message saying: Unknown USB device (Device descriptor request failed).

Any idea how to fix this? My whole history of work is on this drive.

Thanks,

Hello DaisyS,

If the drive is not getting detected on the computer then you could try to connect the drive on a different USB 3.0 port or different computer using different USB cable to check whether it is working fine.

Refer the link provided below for more details.

https://support-en.wd.com/app/answers/detail/a_id/12455

I have now taken this over to a friends and tried on their Mac. The Mac isn’t recognising the drive either. We tried a different drive to make sure the Mac was picking up new drives correctly, and a different drive worked fine so you could see exactly the location it should appear.

So the different computer test is now complete and the drive still isn’t appearing.

Would should I do next? I’ve got years of presentations and personal information on here that I cannot afford to lose.

Thanks,

Debbie

Haven’t received a response to my message above. Could you let me know what to do next? Many thanks in advance.

Debbie