USB device not recognised message on 250gb passport


My 250gb passport has worked fine for a good while (i think its 2/3 yrs old) it doesn’t get used daily, more once a month if that! Anyway, I was bought a 1TB my Passport for my Birthday, I plugged it in, the drivers installed and it worked fine. Only when I went to plug my older passport a little while later it displayed a message “USB device not recognised” !?  Power is getting to the passport, the light is on and I can feel it working if i hold it. I have no idea whether it is broken or its something to do with the new passport!!?? 

I have (for some unknown reason) managed to use the old passport 3 times since these error messages started! It started up fine, I got all my files off it, I then disconnected it, plugged it back in and I got the “USB device not recognised” message! Anyone any ideas???

Did you check if the problem only happens when you have both connected?


The main problems started when I plugged therm in together…the windows that were open on my computer would distort and my laptop would freeze. Since then i’ve never plugged them in together! The issues happen when it is plugged in on its own.  I tried it again yesterday and It worked on the 7th time I plugged it in, then didn’t after that!!