Usb connector broke off


#1

So my 1tb mybook fell off my desk,  the cord caught it and it didn’t hit the ground. The fall dislodged the usb input which came off of the circuit board when I removed the usb cord. Called customer support, complete waste of time. Did some googling which led to me opening it up, removing the sata drive, and putting it in a universal powered enclosure.

Problem is when I hook it up it’s briefly recognized as a new devie, I can hear it spin, but it doesn’t show up on my computer. I’ve tried it on multiple computers and I’ve taken it in to a couple local IT help desks (may be worth noting when i took it in it wasn’t in a case) . One guy told me all my data was corupted, the other told me he could save everything if I sent it in for an evaluation. 

Any ideas what the **bleep** is going on here?


#2

Search for the posts by fzabkar. He has helped some people here that have damaged the bridge card. I think He did one to solder leads to a broken off USB port to connect someway. He’s probably the only one here that knows about that area.

Joe


#3

JOE! YOU ROCK! All kinds of good karma coming your way. 

Going off of one of fzabkar’s posts I bought the exact same drive, took it apart, replaced the sata drive with my old one and it fired right up. Keep in mind I had tried a universal powered enclosure and had taken it to two different computer shops who hooked it up with a usb to sata adapter. None of them worked. I never used wd’s software, no password. 

I know next to nothing in this area but I’m guessing either wd has some sort of proprietary system that requires one of their circuit board docking things or the enclosure I bought didn’t supply enough power. Don’t really care, all I know is it cost  a  $83 to fix. 

Hopefully this helps someone else in the future.