USB backup to private share on EX2

How come I can backup a USB drive plugged into my computer to a folder in the public share on my EX2 without any problems but when I try to back up the USB to a private share I created on the EX2 I am asked for User Name and Password? The private share has a user name but no password and the EX2 does not have a password. When I enter the user name for the share it is not accepted. My PC is running Windows 8.1 and I am using Acronis True Image Home 11. Everything is on a home network. Since the backup works for the public share but not the private share it seems to be an issue with the EX2. I’d appreciate any helpful information concerning this. Thanks in advance.

Try setting a password for the private share and trying again. For a share to really be “private” it needs both a username and password. Yes you can set up users with no password, but then what’s the point?

Thanks for your answer. I am aware that I can set up a password for the private share. That wasn’t my question. If I put in the user name for the private share and there is no password (which is actually a “null” password) for the share then I should be able to access it. My question is “How come I can’t?” By the way, I was looking for “helpful” information. I thought it would be obvious that the private shares are primarily to keep the backup data from different network devices separated. It’s just good data management.

I appreciate my suggestion was perhaps not quite what you were hoping for. Sometimes it can be useful just to get it working first, by whatever means, to prove it can work. Once you know it can work then begin looking at why it won’t work in the way you want it to.

One question I have is this - is the username you are logging onto Windows with the same as the username of the private share? If so, does the Windows user have a password?

The reason I ask this is that Windows will try and authenticate to the EX2 using the currently logged in Windows user credentials. If that user has a password, but the EX2 one doesn’t, then that discrepancy could be causing the problem. Windows may be trying to attach to the share with a password which is different to that which the EX2 has (even when it is null).

When I set up a private on my EX2 for myself, I always give it the same username and password as I use on my Windows machines and it just connects.

If the username of the private share is DIFFERENT to the Windows login you are trying to connect to the share from, then it will ask for a username and password even though the password is null. Why it doesn’t work when you just enter the username is a good question, and I’ll try it with mine.

But again, as I’ve suggested, it is worth just getting it working first even if it is with a non-null password.

Well I’ve just given it a try on my EX2 and seems to work ok.

I created a private (non-public) share called TestShare. I then created a new user called “fred” and did not give it a password. I then ensured that user “fred” had full (read/write) access to share “TestShare” but no other user did.

I then tried to map a drive to “TestShare” from three different PCs, each of which I’m logged into as myself

PC1 (XP Pro) - OK. Asked for a username/password and accepted just the username and empty password.
PC2 (7 Pro) - OK, same as XP.
PC3 (10 Pro) - OK, same as XP and Windows 7

When you say the private share has a “username”, how did you configure this? Did you set things up as I’ve described for my test? Did you ensure that the username you’re using “with the share” has read/write permissions to the share (the default with private shares is DENY)?

See pics below.


Thanks for taking the time to look into this. I double checked and I had the users and shares configured the same as you did with your user fred. Also I can, and have been able to, “map” the share in Windows Explorer, which told me the folder was empty. I did have to provide the share name initially however. Now when I try to run a backup task to the private share using Acronis, as stated in my original post, I get an error message stating “User name or password for the remote resource \WDMYCLOUDEX2\mysharename]mybackup.tib is incorrect.” When I go back and enter the user name when editing the backup task I get an error stating the login is incorrect. When I use my PC user name I can create the backup task without getting an error message but then I get the previously stated error when I run the task. My PC does not have a password, My EX2 does not have any passwords. I have tried the following combinations: My Windows username with no password (becaue there is none), My home group user name and password, my router user name and password (which I didn’t expect to work), my EX2 user name with no password, and the share name with no password (because there is none). All to no avail.

Since the problem is limited to the backup software only, I think it could be a limitation of the way it interacts with the EX2. Unfortunately it sounds very much like a problem I’ve seen before.

I have two NAS units, an EX2 (2 x 3TB mirrored) and an older Seagate Central (single 3TB). I’ve experienced problems with both using backup software to create backups in non-public shares. The backup software I’ve used is AOMEI Backupper (2.8) and also Symantec Backup Exec 9.1 (to backup my Windows Small Business Server 2003 server).

I’ve also experienced the same issue with the EX2 at work, again using AOMEI Backupper 2.8 to backup users PCs, and also the built in backup for Windows Server 2012r2. They just do not like a backup destination share that is not public - at least on the EX2

I have another NAS at work, a QNAP TS-453 Pro, which I use to backup our 2012r2 virtual servers using Backup Assist to a private share. However that has much more sophisticated software on the NAS, which you would expect that for something costing well over £1000 (4 x 4TB drives configured as RAID 10).

I suspect it is some strange quirk either with the configuration of SAMBA on the WD and Seagate NAS units when interacting with processes running on Windows under the “system” account (as most backup software does) or with the configuration of the backup software in how it attempts to authenticate to the NAS.

At the time I just couldn’t be bothered to troubleshoot it too much as I just needed to get the backups to work. The destination share not being private wasn’t a major issue so I just set them as public. I’ll try and take another crack at it this weekend if I can, but it could just be a limitation you have to live with for a while.

I’ll keep you posted if I find anything new…



You might find reading through this useful. It is a thread on the same subject on the AOMEI Backupper user forum. The posts by “georgeh” are me:

Error backing up NAS


Unfortunately is does look like it is common issue with “proper” backup software - Acronis to NAS Private Share Issue. The thread is a bit old but based on your experience, and the similar experience I’ve had with other “proper” backup software, the situation hasn’t changed.

From that I would guess that it is less an issue with SAMBA on the EX2 (and my Seagate Central NAS), and perhaps more of an issue with how the backup software authenticates across home/workgroup type networks. An indication of this is that some people appear to have got backups to private shares to work by specifying the IP address of their NAS, rather than it’s NetBIOS name.



I certainly do appreciate the effort you have put in trying to find a solution. You have really exceeded all my expectations and I feel have gone above and beyond. I have decided that I will just use the public share folder for my USB backups. My system is pretty secure and there are just 2 of us that ever use the system and neither of us does any crazy stuff on the internet. I think we are pretty safe with the public share and it is a lot easier. I could just break down and use passwords but I have more than enough of those already. I will look at the info and links you referenced also. I have researched other NAS devices and decided for my purposes the EX2 was the value, especially since it was on sale at the time. I had been using a WD My Book Live for backups but wanted to go to a RAID system. I had the same issue with it and for some reason thought the EX2, being a “prosumer” device, would work better. Thanks again. I really do appreciate your effort. If I should stumble across a solution sometime in the future I will post it on this thread

Thank you! :slightly_smiling:

That’s what the WD Community is about - helping each other where possible… Besides I just don’t like being beaten by a damned machine LOL!

There are also other options, depending upon how much you want to manage your “backups” compared to software managing them for you. I only use backup software when I want to create an “image” of one of my (several!) PCs so I can recreate it in the event of a PC or it’s hard drive dying.

For data I typically just create a folder (usually named for the date of the backup) and manually copy it in there (usually drag and drop). The next backup I create a new folder and so on until I start to run out of space.

Of course I also backup my EX2 - to an external USB drive plugged directly into the EX2, though there are problems with that which I had an open case with WD support for.

A final alternative, if you don’t mind the inconvenience of removing the USB drive from your PC, is to plug IT into the EX2 and use the EX2’s built in backup utility to back it up to the RAID. It does USB to NAS and NAS to USB backups. Of course there may be a hitch - there are issues with the built in backup utility such as no scheculing of jobs, and it has problems when backing up in “Copy” mode.

Both the “manual” backup and using the built-in backup with the USB drive plugged directly into the EX2 will get round the private share issue. However the “manual overhead” may not be acceptable for you.

With your USB drive plugged into the EX2, the EX2 will share that out!

Your suggestions are appreciated. I went with the software controlled backup so that I can schedule it for a day and time when we are typically not home and the backup is done automatically and incrementally. I used to use the manual method that you described but realized, after repeatedly losing several file updates, I wasn’t reliable enough to do the backup periodically. The USB plugged into the EX2 is an interesting option and I may explore that at some future date. For the immediate future though the backup to a folder in the public share is backup of choice for the USB drive. I am somewhat disappointed that WD doesn’t have the capability to do a backup from a USB plugged into a PC. It seem like it would be rather simple to implement. Thanks again for your help.

The “backup software” method is a very, very sensible choice - that is what I use at work for backing up the servers there (Backup Assist now, used to use Backup Exec 9.1). After all why have a computer and do things yourself LOL! Fire and forget so to speak. This is definitely the case for work where it does a backup 10:30pm every weekday evening (it maintains backups going back over 28 days) and a “bare metal” backup every month.

I might give Acronis (WD Edition) a try as I have a WD Passport HD which should allow me to install it.

AOMEI Backupper is free and pretty good, but last time I tried scheduled backups (v2.0 currently on v2.8) the scheculed job would only run if I was still logged on which I didn’t like. Good backup software should run scheduled backup jobs with nobody logged on using their own or the “system” account.

Backing up a USB drive to the EX2 by plugging it directly into the EX2 hsa two advantages:

  1. Your PC doesn’t even need to be switched on.
  2. It is FAST. This is especially true if your USB hard drives supports USB 3.0. Backing up via a PC is always limited by the PC and, ultimately, your internal/home network speed (recently upgraded mine from 100Mb to 1Gb).

It does however have three big disadvantages:

  1. It is buggy if the backup is done in “copy” mode (currently being investigated by WD Support). “Synchronize” mode works ok.
  2. You can’t schedule a job (agggggghhhh!)
  3. What it reports about how the backup is going and gone (when finished) it terrible.

However plugging a USB drive directly into your EX2 is the best and fastest way of backing up the EX2 itself.

Thanks for the info. I will look into the AOMEI and also the USB drive plugged into the EX2 options. One of the problems with the USB option is that the different computers on my network have different usb drives plugged into them with different content on each of them.