USB backup options in app

Can anyone give me some info regarding what these options do in the USB Backup app …


I want to setup a new job (since going from OS 3 → OS 5, my old job did not transfer over). But if I setup a new job it immediately starts the backup.

I want to create the new backup, and then every time i run the job I want it to update files/folders/structures that have been changed, add new files, and delete files no longer present on the source.

so basically a Source (NAS) to Target (USB attached drive) mrror job is what I’m interested in.


Hi cs7404,
at the EX4100 you can enable USB Backups (now an APP to be installed) you can chose what kind of copy/synch/incremetal method (Backup type) you would like to use. As well there is a button to decide to start the backup automatically as the device is connected or to trigger the copy job manual after the device is connected.
Refer to the online user reference of your device then navigate to the section Backing Up and Retrieving Files

Thanks for that, for some reason when I search online the WD online manuals are elusive …

In section 4, ‘Backup options’, those that are listed are exactly what I see on the NAS but they do not specifically state HOW the backup is being performed.

Like I mentioned above, I would like to know whether the ‘Copy’ or the ‘Synchronize’ options are “mirroring” the NAS structure and content … or they are not ?

I do not fully remember what option i used on OS3, because I setup the job more than a year ago. But I think Synchronize will do what I am looking for.

Just need some affirmation of this, before I have it start the job, wait a few days for it to finish, then check it’s behavior when i re-run the job. i think that’s reasonable to ask and someone on these forums should know that, I have tried asking WD support but low-paid reps simply pull ‘standard’ answers out of a glass jar, hit the easy button and they think their job is done.

there is no mirroring function between source and destination data to work vice-versa!

copy just copies…

  • Copy: Copies files from the source to the destination.

synchonize works only from source to destination

  • Synchronize: Copies files from the source to the destination. This option will overwrite duplicate files.

Incremental just copies the delta of data. maybe this could be your option, even it keeps 10 copied diff files.

  • Incremental: Creates up to 10 copies of the incremental source file changes to the destination.

What I didn’t check is the WD synch software on PC as syncronized the USB with local PC data or via a folder share on the NAS. (I used that some years ago, but disabled it after usb drive went corrupt)

if I delete a file on the source and run the job, what is happening on the target ?
if there is a file present on the target that is no longer present on the source (i.e., i deleted it), does the job put it back on the source ?
don’t really want to store multiple iterations of a single file when the file is changed … simply do not need this function and don’t have the space on the backup drive.

“mirroring” to me means, whatever the source looks like is exactly what I want the target to look like in terms of content. that is simply just what I want.

If I choose ‘NAS to USB’ backup, and pick the option ‘Synchronize’, are these statements true:

  1. any file I add to the source, will be added to the target when the job is run …
  2. any file deleted from the source that already exists on the target, will be deleted from the target when the job is run …

The SOURCE is the original and the USB backup is the carbon copy of the SOURCE, all the time … so this would be a one-way, left to right synchronization. correct ?

conversely, any manual file/folder changes I make within the USB backup will be fixed by the job when I run the job, in order to ‘reflect’ the SOURCE. This is where the term ‘mirror’ is coming from.

I will go for a test to see how the options really will operate.
first it’s important to define the various use cases, … then stupidly run the jobs…modify data , rerun the jobs and note down the results. may adapt the use cases and rerun the procedure. (smells like work!)
So it will be the best method to trust on the options to count on best results …to be very sure on critical data backups…to avoid to end up in a mess when data needs to be recoverd

no need to bog yourself down … i went ahead with a new synchronization job.

as suspected, the My Cloud is completely unresponsive with roughly 5% of my NAS content copied so far to the USB drive … i can see files being added very slowly on the USB from within macOS Finder.

and no surprise that it’s been roughly 12 hours since the backup job was created and started. can I expect this to take another day or 2 to complete … idk.

it may be a limitation of the physical connection (USB) that things are moving sooo slowly, but in the end as long as the complete backup is done with files verified, i can live with that.

future syncs i believe will be quite fast (as they were when i used OS 3).

just an update … the backup is still going, with about 2.5-3TB left to copy (out of a total of about 5TB of data on the NAS). The copy speed is like what you would expect copying files via file explorer over wifi … it really is that slow. but the 2 devices are directly connected to each other via USB.

After 24 FULL HOURS running, i have had NO success getting into the NAS dashboard (i get an unexpected error message when trying to login) - i cannot see the job progress/ % completed.

so strange.
I still have other issues with web / iOS App access. so unhappy with that OS update. they made it really bad and performance has decreased (not measured but access via ipad is much more slower as by OS3). let’s see if I will go for the test, I am so tired to watch daily to the NAs for some hours to get troubled fixed. I need to change access for remote users of my family and friends because of huge index process…this update needs nobody of the traditional NAS users

I really like this thread. . . good information.

In my case, I LOADED the NAS with data from a USB drive. . . because doing it wirelessly was too slow; and I didn’t want to tie up my computer. . . .it took a while; but it was DRAMATICALLY faster then WiFi.

Once, data was loaded onto the NAS; THEN I allowed web access and it took about 40 hours to index ~1-2TB of data.

So – - -I did my tests a few versions of OS/5 back; but I don’t think the copy process should be as slow as you describe UNLESS the initial index job on the NAS is still running. I wouldn’t count on ANYTHING working on the NAS until the index job is complete.

As an aside: In OS/3; the default is to index a new USB drive when plugged in. Not a big deal if the USB drive is a 8gb key. A nightmare if the USB drive is a 4TB external drive. Basically. . .locked up the entire EX2 unit. This has changed in OS/5 (thank goodness) to a default of “no web access”; which means it won’t index the USB key unless/until you tell the system to put the drive on the web.

based on this, it sounds like im in the worst scenario i could be.

it is probably indexing, dont know why it takes soo long to do that. at the same time i am mirroring the NAS’s 4.5 TB onto a 5 TB usb drive.

users should have an option to index or not or set times of day when its ok to index. since this process makes the unit run like molasses

reporting back just now, the 1st job just completed. according to my log, that took 65 hours.

one thing i was not aware of, since i use the Twonky Server app…is that the NAS is indexing EVERYTHING, including what’s on the attached USB drive.

I was advised by WD to turn off twonky, eject the usb drive and reboot the NAS then reconnect the usb drive but i would not do that while it is in the middle of the backup job.

anyway, i trust everything copied correctly.
if i can find a detailed log of the job somewhere on the NAS (ssh), ill have some confidence that backup files integrity is in tact.

USB backup app is now version 1.22

i saw that as well, but call me an old dog for not updating right away.

dont want to deal with a broken backup again. not looking forward to picking my nose for 65 - 70 hours to redo it if something does break.

What changed in the backup app?

idk but i’d like to know as well. will look for a changelog.

from what i saw, the transition from OS3 → OS5 didn’t really accomplish anything meaningful for me and if anything it took away some functionality I had with the app (no ability within app to make a ‘COPY/PASTE’ of a file, for instance), on OS5 I now have to access my backup jobs by hoop-clicking thru the dashboard to finally get to the app and click ‘Configure’ just to see my jobs.

I thought the new USB backup app was needed with the new OS5 firmware ( shame on me)

and I so see a few problems.

  1. on creation of job - the ui only shows me 2 options ( copy and sync )
    it is not tell after the job is created and I use modify do I see other job types.
    AND as we all know the job AUTO starts after you make it.

( the user notes do NOT tell you that )

  1. the sync task takes at least 2 x longer as a copy task of the same data.
    used a test of 50 GB of small files to a blank USB WD mybook for each test.

  2. a few backups that worked under 1.21 fail with a message of ( check you used setting ) – the only fail in a USB backup I have seen in years was ( out of disk space )

  3. on my ulltra2 after the new firmware this week there is some wonky stuff getting back into the main ui page it flashes the password setup then jumps to a mostly working first page - after the default timeout does a logout chrome can get back in after the user name /password box is done. – this is slowing down my backup testing. and may just be a browser problem

if you set the job type FIRST before setting source and destination
you see all 3 options copy,sync,dup

if you set it last the last type is cut off in the list (at least with chrome)

with the current USB Backup app from wd, is it possible to set a schedule ?

under the job detail i see an option to run when connected but haven’t messed with it. the usb drives are always connected so idk what that option would do in my case.

back when i had an old my cloud model it had that option to choose a day/time to run but that NAS had backup built in to the OS.