USB attached drive can access only when enabled with Public

I have a 3T My Cloud with a USB 3.0 4T External HDD.

When the “Share” for external HDD enabled with Public, every one can read/write the content. 

When the Public is “Off”, no one, even for user with “Full permission” to the share can not read or write. Even though the share is still listed in \MyCloud device in Windows Explorer.

Anyone else had similar experience? 

Running latest v03.01.04-139 firmware

The drive was formatted as ext4, and thought that might be an issue.

Later changed to GPT/NTFS (due to 4T size), still doesn’t work, but in a slightly different way

Inability of making the exteranl HDD attached via USB private share is quite concerning.

Part of reason I went with My Cloud was it’s USB 3.0 expansion port to leverage my USB3.0 external HDD. Now it’s in limbo state…

Similar issue…, I can’t access when is not public, with full access to any user they can’t see the usb drive attached …this happens only using iMac, using windows 7 no problem at all, I can access being public or not, I’ve tried several HD and flashdrive and the problem is there, with my ipad o iphone no problem… so only using iMac with Mavericks I have that issue.


Similar issue for me on OS X, no solution yet

Yep, what you said in that link is what happens to me… which is really annoying, This issue makes unusable my hard drive so… I don’t know if I should return WDmyCloud asap.

Me too thinking to return the WD MyCloud because if the expansion never works, then it defeats the very purpose.

Surfing on internet I have found a “half solution” for this… It is using My Cloud app for desktop, it is not the best solution but at least let you access to your no public usb drive attached, It has a lot of limitations but… until decide whether I return my WD MyCloud Unit…