USB 3.0 not working - USB 2.0 works

EDIT:  Since I’m not getting feedback on my issue (I know it’s a pain to be greeted by a wall of text) - I’ll just ask a simple question:

Anybody out there using any of the WD USB 3.0 external drives?  If so, any problems?     

you may want to skip the rest of this :stuck_out_tongue:

I have 2 of the WD My Passport SE 1tb drives.  My main laptop is a new Lenovo X220 with one USB 3.0 port.

Here’s where I am now:

1.  Each drive worked fine on the USB 3.0 port when only one drive was installed (that is, the second was NOT connected via a USB 2.0 port).

2.  Only one drive was recognized if both were connected to the laptop.  I solved this by going to Disk Management and right clicking “offline” to turn “online”

3.  Obviously, I don’t want to do step 2 everytime, so I renamed my drives:  My Passport Red and My Passport Blue.  Everything seemed to work fine.

4.  I then connected my Red drive to my desktop to transfer files - I only have USB 2.0 on the desktop.  Everything worked fine.

5.  I come back to the laptop and the Red drive is not recognized by the USB 3.0 port - nothing shows in “My Computer” or in Disk Management.  It does connect properly through USB 2.0 (and I get domething like “this device can perform faster by connecting to USB 3.0 port”)

  1. Still on the laptop,  I disconnect Red and plug in Blue - it works just fine in the USB 3.0 port.

  2. Connect Red to a USB 2.0 port and am now backing up my Red files to the Blue drive. 

I’ve searched here and read what I can find about USB 3.0 not working - my drivers seem to be fine, cables seem okay - although I can switch them once my backup finishes if there are no other ideas. 

I’m still in the testing phase with all this, but thought I’d throw it out here in case one of you can lead me in the right direction.

Thanks - and sorry for the long post.

Update on what I’ve tried so far (continuing from above post)

8.  After backing up my files on the Red drive, I re-installed the WD SES Driver for x64  (running Windows 7 64-bit)

9.  Red now works on USB 3.0.  Tried Blue on USB 3.0 - it works, I cannot safely eject it - says another process is running.  After waiting about 10 minutes, I can safely eject Blue. 

10.  Now Red is NOT recognized when in the USB 3.0 port.

QUESTION:  Have I messed something up by renaming my drives?  There seems to be some type of conflict when I go from one to the other, even though I am safely ejecting.  Will try a reboot, and also try giving them a specific letter in the disk management window.

11.  Reboot - it wil recognize Red or Blue in  3.0 USB port.  Once I safely eject a Passport drive, it is not recognized in the USB 3.0 port if I plug it back in.  This happens even if I don’t try to interchange drives in the USB 3.0 port.  Leads me to believe something is not working correctly with the “Safe to eject USB device” process.

12.  Did try renaming the Passport volume/letter to X and W, instead of using the default that is normally assigned.  Made no issues to above problems.

I realize it’s unlikely anyone can help me sort is out, because there are probably not too many people with 2 of these drives, and trying to move them from USB 3.0 to 2.0 - and back again.  If anyone is doing something like this, it would be great to know if it’s working or not. 

At what point does WD respond on this. Somebody please link to any official responses to this problem.

My WD 1TB usb 3.0/2.0  also does not work on 3.0 while it works on 2.0.  It started out working just fine on 3.0 but after about a week I plugged it into the 3.0 port on my Gigabyte Mobo and the light came on solid but the it never registered with W7 64bit.

Why!? Support response please.

I’m a C#  developer, electrical engineer and have tried all the driver updtaes and resetting the usb hubs. Hopefully its just some combo of clicks and updates but WD needs to step up on this.



I have exactly the same problem:

W7 SP1 64bit

Z68MX-UD2H-B3 (Gigabyte Mainboard with Etron USB3.0 Controller)

My Pasport 1TB USB3.0

Newest drivers and firmware on all devices

Works on USB2.0

Doesnt work on USB3.0

I hear Windows when plugging into USB 3.0 port and the devicesmanager flickers for a sec, but no new devices is being detected. Unplugging wont play any sound, however plugging it in again plays the sound of a newly attached device again.

Using a Micro_USB2.0 cable in the 3.0 port works also!

Sometimes it gets a connection, but loses it after a while.


Thanks in advance!!!


This is just a users forum not WD tech support. Apparently nobody has an answer to your problem. WD basically just moderates the forum.



I have to agree, however as you might have experienced yourself. The support you get in such communities is way better than via hotline.

Ill give the hotline a try tomorrow. I bet they wont have a clue!

Ill keep you posted, in the meantime: Any idea what might be the reason?



I realize this is a user forum - just trying to get a handle on whether this is an issue with the drives or my laptop.

I did contact WD support - their only answer at this time is to point to a possible compatibility issue with my Lenovo laptop.

It seems more people may be having this problem, so maybe there will be a solution some day …

I think this is a complex problem because a lot of the hardware like MBs were made before USB 3.0 was fully finished. Then you have people trying to upgrade old equipment with add in cards. I don’t know how well USB 3.0 is handled in Windows 7 let alone XP and Vista. It seems to be a problem for some people even with new systems that came with USB 3.0 installed. About the only thing to do is start at MB looking for updates for BIOS, drivers, controlers, etc at the manufacturer and all the way thru the system to the USB port.



What I found out at the weekend: It seems to be a incompatibility between the controller-chip used for the “My Passport” (Jmicron) and the chip used  on new mainboard (Etron EJ168).

If that’s really the case I really hope that this can be fixed by some kind of driver-update and/or firmware upgrade.

I also opened a ticket at the hotline a few mins ago. They just took all relevant information and will get back to me in a few day (I’ll keep you posted of course).

Best regards


Joe - I agree that it is a complex issue.  Also, not all that many people who have USB 3.0 are using My Passport drives - so it will take a while to iron out.

Mine seems to work most of the time on USB 3.0 - the key (for me, anyway) seems to be to NOT plug it into a 2.0 port.

Look forward to hearing your answer, quicky.

shazza wrote:

EDIT:  Since I’m not getting feedback on my issue (I know it’s a pain to be greeted by a wall of text) - I’ll just ask a simple question:


Anybody out there using any of the WD USB 3.0 external drives?  If so, any problems?     

The answers are “Yes” and “Very big problem!”

I bought a MyBook Essential USB 3.0 (3 TB size) 2  weeks ago.  One week ago, I got a USB 3.0 expansion card (PCI Express 2.0 1x connection) for my desktop PC.  The MyBook, when plugged into either of the USB 3.0 ports using the provided USB 3.0 cable, worked as a USB 3.0 device for about one day.  Transfer speeds were awesome.  But that was short-lived.

Since then, every time I plug the drive into my desktop’s shiny new USB 3.0 ports, it always gets mounted as a USB 2.0 device.  WIndows 7 taunts me with the “This device can perform faster…” balloon, but there is nothing I can do.

To forestall the inevitable questions:

-yes, I have the WD SES driver installed

-I tried reinstalling the drivers for the USB 3.0 port card.  They’re as updated as they can get.

-Likewise BIOS.  Asus hasn’t released a new BIOS for this motherboard since 2008.

-I even moved the USB 3.0 port card to a different PCI Express 2.0 slot.  No help.

-Getting really desperate, I tried the USB 3.0 port card in a different computer.  The MyBook still would only connect as a USB 2.0 device.

I’m stumped.  I have no other USB 3.0 devices, so I can’t tell whether the problem is with the USB 3.0 expansion card, the MyBook, or maybe the cable.

The problem was in either the MyBook enclosure or the supplied USB 3.0 cable.  I removed the 3 TB drive a couple of days ago, put it in a new enclosure, and it now has no trouble being recognized as a USB 3.0 device.  I wanted to dump the MyBook enclosure anyway, once I learned about its malicious hardware encryption.