USB 3.0 not working on windows 8

I have a WD My Passport 2TB and I recently bought a pc and installed windows 8. When i connect my drive into USB 3.0 it installs driver then it kind of flashes the safely remove icon on and off really fast in the toolbar and does not come up on computer and unable to access. I have tried other 3.0 Hard drives and they do work so it must be something with the hard or cable but i dont have a double for either to test. Any ideas? I hope this isn’t a dead forum… Oh and it works fine on any 2.0 ports including my pc. Just having issues when connected to 3.0. I tried connecting it to a friend’s PC as well and it didnt have the flashing icon effect but it did install driver but didnt read the hard. he also has an identical drive and we found that our drives only work on one of his front usb ports which must be a 2.0 based on the speeds through it and the other one doesn’t detect the hard drive but like i said installs driver.

See if is possible to update the drivers for the 3.0 controllers.

Connect the drive to the 3.0 port and see if it shows on Disk Management.

It flashes on and off disk management very fast and Im not sure how to check the drivers for my “controllers” my motherboard is z87m-plus by asus

I think its notable that i am running windows 8.1 and this is a fresh system i built myself so this is the first OS the motherboard is using im pretty new so idk if thats even relevant

Check the MB maker’s site for any updates and if you are uning a card for USB ports check that manufacturer’s site also.


i dont see which one of these relates to USB 3.0 drivers

I uninstalled eXtensible driver and reinstalled, now it doesnt flash and shows up in device manager too but shows an error

This device cannot start. (Code 10)

{Operation Failed}
The requested operation was unsuccessful.

Also notable that it connects fine to my cousin’s 3.0 port on her laptop.