Upsizing a 1 TB My Book Studio Edition II in RAID 1 to 2 TB without reformatting?


#1

I bought a 2 TB My Book Studio Edition II a while back, using it happily in RAID 1 configuration.

This week I purchased 2 WD Caviar Green 2 TB disks, to replace the existing 1 TB disks. I removed the first 1 TB disk, and put in the 2 TB, letting RAID restore itself, which worked like a charm after about 5 hours. Second drive, same thing, everything OK.

Problem is though that I was hoping to get about 1 TB free space in Mac’s Disk Utility… But that’s not the case. The drive still appears as a 1 TB disk. I still have the original 1 TB disks untouched if needed.

Is there a correct way to do what I wanted to do, and get 1 TB free space available, without erasing/formatting and restoring the partitions on a larger volume?

Thanks & cheers --Mike Carpentier


MyBook Studio 2tb – Upgrade drives?
MyBook Thunderbolt Duo - Upgrade drives?
#2

The old firmware might limited the drive capacity to 2TB total.

New firmware might fix that 2TB limit.

Before you updating to the  new firmware. 

I suggested that you need to keep your original drives just incase

the firmware update might erase the new partition on the new drive.

Please check out this link

http://support.wdc.com/product/download.asp?level1=1&lang=en


#3

Assuming I am willing to reformat the drives and loose all data, will a My Book Studio II bought with 2x500MB drives support 2x1TB for a total of 2TB @ RAID 0 / 1TB @ RAID 1?

Also, is it possible to replace the drives with 32mb cache size drives instead of 16MB cache size?

Thanks!


#4

Chompy18,

You need to check this link to see if there firmware is available

for your drive before decided to buy a new drive.

http://support.wdc.com/product/download.asp?level1=1&lang=en

For drive cache size I do not think is really matter.

If you want to put 2x 1TB,  either Raid0 or Raid1 configured, It should be fine.

The 2TB partition limited is the only issue.


#5

Hi there,

I’m pretty sure that as you posted this 4 weeks ago, that you already know the answer, but here’s my experience.  Existing drive was a 2 TB (2x 1TB drive) WD My Book Studio Edition II .

Short answer is yes - provided that you’re willing to remove the existing drives , and put in 2 new WD Caviar Green drives (I could only afford 2x 1.5 TB drives), you should have no problem.  I haven’t tried this by putting in a single 1.5 TB drive and hoped for a space increase - my guess is, it won’t work.

It is somewhat misleading however.

You DO need to uninstall the WD Drive Manager application first (launch the original installer, then uninstall).

THEN install the latest firmware release for the WD My Book Studio Edition II firmware update 

http://support.wdc.com/product/download.asp?groupid=114&sid=103&lang=en

Once you’ve done that and done the precautionary reboot (and follow the instructions, if it’s on FW, make sure you reconnect on USB), it STILL says that it’s a 2TB drive in my info (even though it’s actually 3 TB in my case).

It was only until I installed the latest version of the Drive Manager installer, and reformatted as Raid 1, that it recognised that it was actually 2x1.5TB drives.  I am paranoid so wanted Raid 1, but I’m sure that if you also used Drive manager to change to Raid 0, it would also see it as a 3 TB total drive.

So, it does work, but make sure you follow the process, as it can be somewhat misleading along the way (and if you follow the process you probably won’t swear unnecessarily (as I  did)).

Good luck.


#6

hi there

I have a slightly different requirement, my existing studio ii (2TB) is already full and I am looking for possible replacement.  One possibility is to purchase 2x2TB and install this on my studio II, would you know if it is going to work?  Assuming it is possible (and assuming I need to update the firmware), if I put in the old disks (2x1TB) back to the case, would my mac still see the 2x1TB?

thanks very much.

Julian


#7

I’m nearly out of space too and wondering what my best option is …

Does it work if you replace the 2 x 1TB drives with 2 x 2TB drives ?

I’m looking to get a maximum capacity of 4TB.

Does anyone know the answer, as WD support told me it is not possible.

(I already have the latest firmware installed, and have a second backup of all of my data.)

Thanks.


#8

I have made the replacement from 2 x 1 TB to 2 x 2 TB (WD Caviar Green disks), so YES it works. I have them now configured in a RAID 1 setup with 2 partitions (800 GB for Time Machine, 1,2 TB normal drive).

It wasn’t possible to do the upgrade in the intelligent way I was hoping for. If you replace 1 of the 2 disks, mirroring will work, but the 2 TB disk will be formatted to 1 TB :frowning:

So I bought a SATA docking station, took out the 1 TB disks, stuck in the 2 TB disks, configured the drive the way I wanted it (2 TB in RAID 1, 2 partitions), and copied the data from the 1 TB disk in the docking station.

I stuck the remaining 2 1 TB disks in a D-LINK DNS-323 NAS enclosure (RAID 1), which is functioning beautifully as well.

Cheers --Mike


#9

I took a bit of a gamble, but it paid off …

I started out with a 2TB My Book Studio II which I outgrew.

I replaced the 2 x 1TB drives with 2 x 2TB drives and it worked first time.

Drive Manager automatically set them up at RAID 0 for me, so I now have a total capacity of 4TB.

I used the “Western Digital WD20EARS 2TB Hard Drive SATAII 64MB Cache - OEM Caviar Green” drives as an upgrade.

WD Support told me it would not work, but on checking back with them they said it would work but the issue is warranty - the 5 year Warranty covers the original chassis and original drives, so if I ever had a problem then I would need to return the drive in it’s original condition i.e. with the original drives back in it. (So I’ll be hanging on to the original 1TB drives just in case.)