Ups, we did it again! - Dashboard version 3.6.2.7 does not start, either!

Upgrade from version 3.4 crashes at the loading stage, in exactly the same way as 3.5.2.7 did…

Shame on you, WD Team! When are you going to fix it?

1 Like

Where’d you see 3.6.2.7 posted?
The latest is 3.5.2.7 released March 2022 if I’m not mistaken.
I wonder if the dashboard software is notifying of a new version before they post it to their website.
For reference, there are dozens of us on here complaining about 3.5.2.7 not loading for us, most downgraded using a link someone posted to download Dashboard version 3.4 but (I’m suspecting here) the files keep getting pulled from file hosts by what I can only assume is Western Digital filing copyright claims.

As I can see in the other thread, you’ve found it already.

Yesterday I received an email from WD support, with “a solution”. They instructed me to uninstall the current version and install the one from the following link: Software and Firmware Downloads | WD Support :smiley:

But the best part of this solutions is: “If the installer fails to load we suspect the drive may have errors and needs to be replaced.”

I am downgrading back to 3.4 now…

1 Like

Sounds like support is worthless. Their application development team may be unaware of this issue due to the incompetence of their Tier-1 support team.

2 Likes

The funny fact - version 3.4.2.9 also reports these problems with Chroma in the log. But it does not refuse to work :slight_smile:

Interesting observation - are you sure those log entries are for the current version and not leftover from the other install(s) of 3.5+?

Watch someone here figure this out before support even gets a whiff of it lol

They put out even newer version Crashes exactly same as one before Kinda sad

Can confirm. Having the same issue.

I uninstalled Razer Chroma and then I attempted a clean install of WD Dashboard after a reboot. Well, still getting this error:

C:\Program Files (x86)\Western Digital\SSD Dashboard\dashboard.log

Sun May 8 13:47:39 2022 0x1a55de0 Critical:  -- js: "Chroma connection FAILED FILE_NOT_FOUND"
Sun May 8 13:47:39 2022 0x1a55de0 Critical:  -- js: "Uncaught (in promise) #<Object>"
Sun May 8 13:47:40 2022 0x8fca2d0 Warning:  -- Failed to download disables and quirks for "WDS200T1X0E-00AFY0" "613200WD" "inbox"

I’m having the same problem. Software did an upgrade from 3.4.2.9 and hasn’t worked since. 3.5.2.7 and 3.6.2.7 both will not work. Was working fine with old software. Software starts up and then shuts down after about 6 seconds.