uPnP DLNA Search can't find mp3 tracks

Hi,

If I try to search for mp3 music where there is a single quotation character in the Title or Artist, then the search returns No results.

I have tried to substitute the single quotation character with various standard Escape sequences ie %27, but no good.

Can you please tell me what the work around is?

Thank you

Pedro

Welcome to the Community.

Do the files appear if special characters such as quotation marks are removed?

Thank you very much for your reply.

Yes - if I use a program like MP3TAG and remove the single quotation mark from the file, it works. ie I have:-

Ain’t No Mountain High Enough, by Marvin Gay

I cannot Search for this by Title because the WD can’t process a search with a single quotation in it.

I can find this item if I Search by Artist (Marvin Gay).

The same problem exists when searching for Artists like Johnny O’keefe.

I have tried using common Escaping sequences to overcome this. ie
Ain%27T
Ain&quotT
Ain/'T
None of which work.

Do you know what will work?

Thanks
Pedro

Hi,

After some exprimentation, I have discovered that the “_” (underscore) character acts as a single wildcard therefore I can substitute “’” with “_” and set the Search to “contains” and not “=” it works…

I have also discovered that it is not only the “’” (single quotation) character that the WD is sensitive to, but also “%”, double quotes, and “” characters.

The solution above can deal with this too.

Unless someone has something better that works…