Uploading big file fails


When I use WD My Cloud Desktop, the software, to upload data to my MBL, it fails on files larger than 2.93GB.

If smaller, they will be uploaded. Additionally, if I copy directly to the MBL through network and shared folders, it will work.

So far, I’ve given the MBL a static IP and its set to DHCP.

I already resetted the MBL and I turned SSHL on or whatever this was called.

I saw others had the same problem but there was never a solution so far.

Can anyone help? This bug is really a bit embarassing so far, would like to fix it.


What firmware are you running on the MBL?

I couldn’t understand this part (So far, I’ve given the MBL a static IP and its set to DHCP.)

If you set an static ip on the drive, and then set the drive to DHCP, the static ip will be removed. You can assign an static ip or set the drive to DHCP not both.

Are you trying to copy the files within the same network with the app or remotely?

Ok with DHCP I don’t know. My router is set to DHCP: active but I gave the MBL a static IP. However, I didn’t have to give it a gateway and so on.

Well it does not fix the problem anyway.

Here’s the firmware: Version:MyBookLive 02.43.03-022 : Core F/W

Yes I try uploading in the same network from my laptop with Win7.

The problem appears when I use the software WD My Cloud (for Win7).

I can simply copy to the shared folder under network, but that’s much slower than with the WD software.

I tried all kind of connections. Basically the laptop is on wifi and the MLB is connected to the router by cable.

The problem is not solved if I connect the laptop with a cable to the router, too.

Neither is it solved if I connect the MLB directly to the laptop by network cable.