Upgrading drive in My Book Live

I successfully replaced the 3TB drive in a My Book Live (Firmware 02.43.09-038) with a new WD Green 4TB drive.

The Data Volume in the MBL is formatted with a non-standard variety of the EXT3 file system which is not readable by most Linux computers. On a previous attempt I’d used LinuxReader in Windows to copy the data from the 3TB to the 4TB drive, but later I discovered that it had miscopied a lot of files. Most .AVI files would play for the first 20 minutes and then die. I don’t know if this was a deficiency in Linux Reader or if it was caused by something else. I also tried using the fuse-ext2 driver in Linux, but that didn’t work at all. Knowing all of this makes me reluctant to depend on the MBL. If the motherboard in the MBL were to die, I probably couldn’t retrieve the data from the drive, even if it were still functioning.

On my third attempt, I connected both disks to an Ubuntu desktop and used dd to clone the 3TB drive to the 4TB drive:

sudo dd if=/dev/sdb bs=4096 conv=sync,noerror of=/dev/sdc

The copy took about 10 hours (my previous tries were attempts to get the job done quicker). I could monitor progress by opening a second terminal. First I determine the PID of dd with

pgrep -l '^dd$'

And then setup a watch to tell dd to printout a progress report every 60 seconds:

watch -n 60 sudo kill -USR1 pid#

After the disk cloning was complete I moved the new 4TB drive into the MBL and started it up. At this point it worked perfectly, but My Book Live still only reported 3TB of space --the extra 1TB was sitting unused and unavailable at the end of the disk.

The sixth post at this forum (by tomas123) tells how to resize the partition using parted, e2fsck, and resize2fs, all of which are already installed on the My Book Live. I followed his log, with just a couple differences:

  • mionet is no longer included in current firmware so there’s no need to stop that service.
  • umount /shares failed with an error message each time. On one attempt I issued the command /etc/init.d/smbd stop , after which umount /shares succeeded. The second time stopping smbd didn’t seem to have an affect, but waiting a minute or so and typing umount /shares again did allow /shares to unmount.

Resizing, etc, took an hour or two. After restarting, My Book Live reported an extra 1TB of free space, and still reports that the drive SMART status is OK. The drive still spins down when the MBL is not being used. Since the MBL ships with a WD Green drive, I’d be reluctant to put anything else inside. It could affect SMART reporting or drive spindown.

1 Like

Welcome to the WD Community,

Wow, nice one.

Thanks for sharing

Will be good if you include on the post that this procedures are not supported by WD and that it will void the warranty on the unit.

Congrats to you, thaipaw. Would be great if others shared their experiences with drive upgrade. Bigger drive sizes, other drive series than WD Green and similar…