Upgraded to Windows 8 and now network shares don't all show up HELP


I feel like I have tried everything on the forums. In the past I had a Win7 PC and USB drives that I shared on my PC would generally show up as network shares on WDTV Live Hub without too many problems.

I have switched to Windows 8 and I am trying to get the same configuration working. It is a wired network. Drives are connected via USB directly to my box. One of my USB drives is showing but two others are not. I have two WDTVs and have same behavior from both.

I have played with all the advanced network settings and media streaming options. I have switched the WDTV to manual network setup and given it a fixed IP. I have played with setting up a new local Win8 user and using those passwords. I have played extensively with share options and advanced permissions. None of these things have worked.

Anybody else having this issue, any other solution to make Win 8 work. 

I do appreciate any help!

Make sure the Hub is in the same workgroup as the PC. By default windows and the Hub use the name “WORKGROUP”.


Maybe this might help: http://wdc.custhelp.com/app/answers/detail/a_id/3787



I have made sure that I have the Hub and PC on same workgroup. I have played around with workgroup name to make sure that the name is not the issue.

I should add that I’m running Windows Pro 8.1. The tutorial you linked me to said I should turn the network into a “work” network. I don’t believe I have that option in Win 8.1. My two options seem to be Private or Public only. Perhaps this is the source of my problem. Regardless, whether I switch to Public or Private the behavior remains unchanged.

FYI networking interface and switching network locations looks like this in 8.1:


Well I guess it was of no use then…sorry.

Ah … no prob at all… I’ll try anything in search of a solution for this.

I have also made sure that my computer is the Master Browser. It had not been previously. I feel like I have tried every configuration of settings.Computer Browsing on/off, all different share settings…

Still looking for answers here.

I have two shared USB drives that can be seen by the Hub and two that cannot.