Upgraded to v04.04.02-105 / Now Backup Speed is Horrible

Hi All,

Please advise if others have encountered the same.

This morning I upgraded the firmware of my WD 3 TB and now my backup speeds have gone down below 10MB’s per second. My wireless connection is shut down. The local Ethernet segment is configured 1o 1 gig full. What gives?

Current build is v04.04.02-105 .

It has been about three hours since I upgraded the firmware so I would believe the database is synchronized.

For me the question is now, how to I downgrade?

Thank you.

I would not automatically assume that the Cloud drive is at fault. That will lead to untoild agony as you disrupt current Cloud operations. After a FW update there are lots of housekeeping activities that need to be done and as we all know, TTT = Things Take Time! Hang in there.


If you have a lot of media, it may still be re-doing the thumbnailing/indexing.

I’d give it a day or two, and see if it improves…

Thanks all for your comments. Will hang in there for a couple of days and see what happens. I do not recall this happening last time I performed an upgrade.

Thanks again for the comments.


So far, the FW update seems to have messed up the Safepoint process. I am attempting to see if there is a workaround. The Cloud does not recognize the previous Safepoint and it also reports no space available on the USB drive.

More later.


Status quo:

My max speed uploading is 9.xx MBPS with the Ethernet port on the PC set to 1 gig full duplex. Tried setting the Ethernet port on the pc to 100 mb full and saw the same results. Rebooted the wireless router, which had no effect. Rebooted the WD My Cloud 3 TB and again no effect -.

This is definitely associated with the upgrade. What baffles me is that others do not seem to be affected. The backup process worked fine previous to the upgrade.

Working on it. Will advise. Thanks for the input.

Hi Support at WD.

Can you supply a link to the previous build so I may migrate back to it - please?

Thank you.

See the following thread that has more information about prior firmware versions and how to roll back (if one can).

Note: Rolling back the firmware may cause certain features like remote access to stop working.

1 Like

Thanks much Bennor.

I had been checking around but did not see that one.

Cool beans !

Yep messed up my USB safe point. Doing a new, full safe point again. It failed earlier with USB drive error… hopefully it will complete.

I let my WD My Cloud sit there for a few days. At one point or two I backed up some files and was seeing normal transfer rates for me, which is somewhere in the ballpark between 30 - 60 MBPS. Tried it a couple times this morning and again now I am seeing severe degradation with upload speeds not exceeding 10 MBPS. The WD My Cloud 3 TB at my locale is used for backup only. .

There is no question for me at this point - downgrade.

Thanks for all of those providing input,

Continuing the discussion from Upgraded to v04.04.02-105 / Now Backup Speed is Horrible:

If you disable thumbnail caching (have to tweak it via SSH, there’s a topic on here somewhere), does the transfer speed go back to normal?

I’m coming from a very old firmware version and want to upgrade to the latest one just cause it’s tempting. I’m seeing a lot more issues than positives though…

Hi chaoscreater,

No I have not tried to disable thumbnail caching. Not sure how to do that and I will not as I am not seeing issues right now.

In reference to you trying the upgraded build, as I have not seen others mentioning degradation in throughput speeds in this post, how much can you rely upon one person ? Not to confuse things, but I am the original poster. No one else seemed to complain about degradation.

The only other mention of a problem in this post had to do with the Safepoint process. There was also something to do with reporting of available space on the USB drive, not to disparage any post or issue.

In my opinion, the personnel at Western Digital (WD) provide these builds to fix specific problems that either they have seen in their labs, or more precisely, what personnel have reported to them through various means.

If you do not have any perceived problems, and if it does not seem to be broken for you, why try and fix it with a new build? I understand and respect that you are most likely not actually trying to fix anything. Many of us upgrade as it is always greener on the other side, and we all want our software to run perfect and flawless. It is rare to see software written by humans to be perfect, or run flawless.

Although upgrading and downgrading are simple as far as I am concerned, there is always a risk, albeit minimal, You could ask the software developers at WD if there are potential issues in upgrading and then reverting back to the original build you were on. A PROM may be upgraded through the process~? The downgrad may face potential issues not seen by this user. I had gone from v04.04.01-112 to v04.04.02-105, which is probably a whole lot safer than going from a v03-xx.xx.xxx build to v04 and then back. Although to be honest, I have not seen issues in reverting back to v03-xx.xx.xxx written in posts. You may want to search on that too.

Anyway, twas some food for thought regarding upgrading.

Happy trails,


Hi All,

I also upgraded to the new firmware (v04.04.02-105) of my WD Cloud 2Gb (WMC4M1204892). I also don’t see my safepoint anymore.

What is the WD official answer to this.

Although I think this is a problem which should have been tested upfront releasing a new firmware, I am OK with re-formatting my USB harddisk and make a new safepoint.

Is there an other solution / official answer from WD to this issue?

I don’t want to downgrade the firmware…if the above solution (making a new safepoint) will work.

Looking out for a reply.

Kind regards,

Marco van Bemmelen

Please note that the Safepoint disappearing issue with the 04.04.02-105 firmware has been discussed in other threads. See the following post for one workaround that appears to work for some.


Another thread on the missing Safepoint issue with the current firmware: