Upgraded my_cloud to latest firmware automatically - device blinking blue light

NAS my cloud drive: part number : wdbctl0040hwt

I have had this drive for several years bought new. I usually let it update when new firmware is made available. Today, it notified me of new firmware (I assume OS5?) and I let it update. When it rebooted it came back with blinking blue light. The disk is fine.
Please help with advice on what to do or how to restore the OS without damaging my data.

Hi @mjz3348,

If the My Cloud power LED is blinking white, or blue, or Solid Amber the file system check process is occurring indicating a System Not Ready state.

The file system check process must be allowed to complete before the unit can enter the Powered on and Ready phase, indicated by a solid blue power LED. Please be patient and allow the file system check to complete

Please refer to the article for more information:What Do LED Blinking White, Blue, or Solid Amber Mean on My Cloud?: What Do LED Blinking White, Blue, or Solid Amber Mean on My Cloud?

Please contact the WD Technical Support team for best assistance and troubleshooting:

this is a crock of ■■■■… The file access has been running now for 2 weeks on mine as the “techs” say it can take several days… well 14 days later and it still won’t work… WTFO !!!

Then they tell you to take it to one of their “partner data recovery” companies… agina, are you ■■■■■■■ serious… ? so you screw the OS so it won’t boot, and now your “partner” wants $500 to recover the data… PHUCK THAT !!! Classaction lawsuit coming in hot

Is there a remedy to this problem? The NAS does not respond to pings and the LED blinks blue. It’s Benn like this for 4 days.

A year later, I have a new issue. My Gen 1 My Cloud, which was working fine, showed a steady white LED for days. Even though my files and normal work was o.k., I decided to shutdown and reboot the drive using the U.I. from the web interface. Now it won’t boot up at all and instead I get a solid RED LED. Nothing I could do (4 second, 40 second reset) worked. The WD red drive is one year old. I took out the drive and mounted it on my linux system and all my files, shares, etc. are there. The drive has no errors (heck, it’s NEW). SMART shows great. Ethernet connection, etc. is normal, I just can’t ssh, telnet or web access it.

I tried booting using a USB stick following instructions on setting up the EFI partitions, etc. to no avail. The unit still starts up solid white LED switching to solid RED after a few minutes. Could the mycloud “plate” have failed? Or is there some other way to get to the recovery U.I.

This site is for OS5 only. Post on OS3 forum