Upgrade to Smartware Pro activation problem

Just purchased a WD My Cloud device that comes with 3 licenses for Smartware Pro — but when I try the activate on my new windows 8 desktop … I get a Windows type of error stating (title of error window is WD Smartware):

Object reference not set to an instance of an object.

any clue as to what I’m doing wrong — or any workarounds?


I am having exactly the same problem, tried uninstalling and reinstalling with no impact, Windows 7 64.

In a separate reply to a similar question … 

JStaff wrote:



This is quite unusual. I would recommend uninstalling WD SmartWare from your system first, then proceeding to clean the registry to eliminate any previous trace of installation before proceeding again. Also, please make sure to have installed all Microsoft Windows updates into your system including the Microsoft .Net Framework 4.0.

I have the same problem — but in Windows 8. I have run all of the Windows Updates, but I’m wondering if in my case the problem is that the default Microsoft .Net Framwork for Windows 8 is version 4.5 — 

— regardless I think that uninstalling Smartware … then peforming a regedit to remove all traces is requiring an awful lot of an end user.

JUST wondering if there isn’t a more “backdoor” way of activating Smartware Pro that doesn’t depend upon Microsoft .Net —

— note I’m operating on a nearly new machine … and near as I can tell should NOT  be having operating system problems!!!

Exact same problem with same error message.  See my post under related subject: Unable to Upgrade to SmartWare Pro.

This happened to me when I first got the device a few weeks ago, and is happening again.  I called support and they had me uninstall and reinstall the soflware.   I was trying to back up Dropbox today and the message popped up again.   I don’t know to “clean the registry” to “remove all traces” of the program and, in any event, am unable to make maintaining the device my full time job.  Any suggestions?  WD?

I posted a reply to a separate ‘string’ on virtually the same topic, that I got help from WD support and they solved the original problem (w/o having to resort to uninstall, etc.), see that posting here:  Re: Unable to Upgrade to SmartWare Pro