Upgrade My Cloud to Twonky 8

Because you have a v2.x firmware version My Cloud you may have to roll your own firmware with the updated Twonky. One can download the GPL firmware for v2.x single bay My Cloud at this link:


Or you may have to use some sort of CRON job to add in the updated Twonky at each boot/reboot of the MY Cloud. Do a forum search for “CRON” using the magnifying glass icon upper right to find various discussions on how to use CRON to get around the problem of changes being wiped out when the My Cloud is rebooted/powered on.

I got this from WD support. Sounds like there’ll be no update anytime soon, and I am not competent to hack the firmware. Before the My Cloud I had a My Book Live which was a lot more open - the Cloud seems pretty locked down. WD probably had to deal with a lot of messed up My Book Lives! Still, it’s a shame you get what you buy and that’s your lot.



" Please receive our sincere apologies for the inconvenience. In regards to your case, upgrading Twonky is possible. However, it is not supported by Western Digital.

We also verified the WD My Cloud specifications and unfortunately it may not work with Twonky 8. We are currently working on it to find a solution. It is usually provided in a form of a firmware update.

We will be sure to keep you posted about any change. As for now, we do not have an update and what will be changed or a release date for the firmware update."

Correct, WD has previously indicated to others that the Twonky media server would not be updated. For those adventurous enough who have the v2.x firmware My Clouds they have other options to try and upgrade/update the Twonky media server. The following may help people get started on their v2.x firmware My Cloud’s.


Hi there,
An official Firmware upgrade mostly improve or fix only Basic functionality of the Operating System Kernel. Twonky is a 3rd Party Software. 3rd Party Software only will be upgraded, if this is absolutely necessary for the kernel function - so nearly never!

If you have a Gen2 device (something like DL2100, EX2100, DL4100, EX4100) with Firmware 2.xx.xx, look at this post:

Using this guide you will be able to generate your own custom Firmware with your preferred twonky Version inside.

Changeing / adding autostart sequences or CRON Jobs inside of the Firmware kernel is not really recommended for People without really good Linux experience and knowledge of Linux os start behavior. Only a Little mistake can make your NAS useless!

Best regards and good luck…

1 Like

I figured out the ssh logon part
but would you be willing to rebuild a mycloud 2nd gen 4TB single drive FW with twonky 8.41
for those who need it ?
Firmware 2.30.165

if there is a firmware source able to download from WD I think, that the creation of a custom firmware is the same way.
Please post the full device type and name here.

Wd mycloud 2nd generation 4gb single drive
Current firmware is 2.30.165
Current twonky server version is 7.2.9-13
newest one is 8.4.1
Thank you so much

I have the exact same specs as this.
Wow, thank you so much you two, especially buchi1000 for the technical expertise.

Don’t mention it!

Based on your given specs i searched in the web to find the correct GPL source of your NAS Firmware.
I can’t understand it, but there is no actual Firmware 2.30.165 GPL source to find.
The latest version i found is v2.21.126 from date 2016-11-10.

So if you want to upgrade your twonky, you must downgrade your Firmware.
But i don’t know the difference between the newest Version and the previous one.
May be, there are some better features in the new one or some fixed security leaks?

So it is your choice to go on this. I can not promise you any success, therefore you must try it on your own risk.
I guess it will work, but I can not promise.


According to the technical data that can be found in the WEB, the MyGloud Gen2 also has a Marvell Armada processor.

I have tested the creation of the MyCloud Gen2 Firmware based on Version 2.21.126 with Twonky 8.4.1 for Armada without problems.
So i think, it will work on your device. but as I said - at your own risk.
And don’t forget: disable the auto-Firmware-update function on your device!

1 Like

Thank you for all your help
I will try and find that 2.30.165 gpl FW somewhere
maybe WD has a ftp with it on it
unless they haven’t released it yet

No problem, if you need further help, let me know.
Greetings from Austria

It hasn’t been released yet. See the v2.x GPL download page.


I know it’s not published yet ,but it might be available upon request
I requested it from WD
Thank you

I successfully installed twonky 8.4.1 on my MyCloud EX4100 (FW 2.30.165) two days ago.
The WEB interface runs smoothly and without problems.
I don’t know why, but the iTunes media library import in twonky 8.3 didn’t work although this has worked well with twonky 8.3 on my MBL. Now the iTunes Music Library import is evailable again. Maybe there is a bug inside of the twonky iTunes import plugin on the twonky 8.3 Marvell package.
So i can define playlists on iTunes very comfortable and use them on every DLNA Device in my home without the need of complex manually export.
If someone needs help to be able to use twonky and iTunes the same way, I gladly offer my support.

ATTENTION: I have to report a heavy bug after updateing to custom edited firmware 2.30.165:

Yesterday I wanted to create a new user. This has still worked. But all functions for sharing and assigning rights no longer worked.
Also different admin functions no longer run. Cloud settings and device names can not be changed anymore.
After the installation of the original firmware everything works again normal.
The exact cause I can not determine.
Whether the other v2.xx.xx devices is synonymous so, I do not know.

So, after a whole day of testing and analyzing, I can report the following:
It looks like the base GPL package already has a bug. If the package is composed (strictly according to instructions from WD) and nothing of the 3rd party modules are modified, exactly the same happens.
After uploading the firmware to the device works a lot no more. It runs the twonky as desired, but many other functions are dead.

So you have to take the thing as it is.
I’m very disappointed.
I assume that all WD devices with FW 2.30.165 will have the same problem.
On a request to WD, whether one can upgrade twonky, I got the nice information: yes, already, but we do not support it.
So a request for a correct GPL package will not bring anything.
Thanks WD - really weak!

Hi guys
No i found a way to use the newest twonky Version on my device.
Look at post Upgrade Twonky to 8.0.3.
Many thanks to QQrQ for sharing his idea.

Wow, OK – I’d given up on this! Thanks for persevering.

I had a look at what you posted. Could you clarify a little? I’m a novice and don’t want to mess up.

Putting the Twonky download in Nas_Prog seems straightforward – that directory is currently empty, correct?

The files from your zipfile extract into a subdirectory called MyCloud_PlexNo/twonky.
cgi_bin replaces cgi_bin the twonky install placed in Nas_Prog, correct?
twonkyserver-default.ini replaces /usr/local/twonky/twonkyserver-default.ini, correct?
What about “twonky” and “twonky.ini”? I haven’t been able to find those in the original mycloud structure, should I move them up into Nas_Prog?

Thanks again,


Oh, and – If I mess up and want to go back, I can just delete everything in Nas_Prog and put the old /usr/local/twonky/twonkyserver-default.ini back, I hope?

I think, my guide is written very usefull.
But I can explain to you once more.
You must install plex media server on your NAS using the AppStore function of the NAS.
You must download the twonky installation zip file from the twonky download page.
You must download one of my zipfiles. If you want to use Plex, then MyCloud_PlexYes.zip.txt, otherwise MyCloud_PlexNo.zip.txt. You must delete the txt extension to be able to unzip the file.
Copy the twonky installation zip into …/Nas_Prog/twonky and unzip it there.
Copy my zip file into …/Nas_Prog and unzip it there.
Check the executable file mode as written in my Guide.
thats all.

You have nothing to change in other directories of your NAS!
Everything you would change in the original firmware structure would be automatically overwritten in case of a restart of the NAS.

I hope, this help.