Upgrade Copy Failure — Firmware 02.43.09 - 038

Anybody got a clue what’s going on here…? I sure don’t :slight_smile:

My Book Live 2TB, tried updating using the Dashboard and Firefox. Current firmware version is 02.43.03-022.

Hi and welcome to the WD community.

Have you tried on a different browser or perhaps on a different computer just in case? Just in case also try to reboot the drive and try again. 

Thanks fot the tip. I tried Firefox and Safari on Mac and Firefox on my Windows 7 laptop. The upgrade stops at 70% with Upgrade Copy Failure.

Hey, if you have had a WDL for any length of time, you should be used to failures.

Count your blessings you got to 70%. After a week, I still can’t get it loaded past 60%.

Hahaha yes I know. I’ve had nothing but connection issues all the time, drive disappearing on network, fluctuating write speeds etc etc. Wish I never puchased two of these boxes. I demolished one MBL and put the hard disk in my Mac so I can actually use the disk space :slight_smile: